aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-firmware
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-15 09:11:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-15 09:20:17 +0000
commit9e768a78ba2bfc0c55395838ceff553f5979e080 (patch)
tree4c8dbd1cc37bc5ad04349cd61a4909d2c371e821 /main/linux-firmware
parent04c64d6f885edb1913cc6ce35708e5e96b0490dd (diff)
downloadaports-9e768a78ba2bfc0c55395838ceff553f5979e080.tar.bz2
aports-9e768a78ba2bfc0c55395838ceff553f5979e080.tar.xz
main/linux-firmware: upgrade to 20180615 and add provides
add provides=linux-firmware-any. This makes it possible for users to pick a set of needed firwmare packages instead of pulling them all in. We also set provider_priority so that if no firwmare package is explicitly added, users will get them all for backwards compatibility. We also provide an empty linux-firmware-none in case some user does not need any firmware at all.
Diffstat (limited to 'main/linux-firmware')
-rw-r--r--main/linux-firmware/APKBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/main/linux-firmware/APKBUILD b/main/linux-firmware/APKBUILD
index 1341651e7a..b9e0f2fb16 100644
--- a/main/linux-firmware/APKBUILD
+++ b/main/linux-firmware/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Oliver Smith <ollieparanoid@bitmessage.ch>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=linux-firmware
-pkgver=20180417
+pkgver=20180615
pkgrel=0
pkgdesc="firmware files for linux"
#url="http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=summary"
@@ -11,7 +11,8 @@ arch="all"
license="custom:multiple"
makedepends=
install=""
-replaces="linux-grsec linux-vserver"
+provides="linux-firmware-any"
+provider_priority=1
options="!strip !check"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-${pkgver}.tar.gz
https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm/brcmfmac43430-sdio.txt
@@ -32,11 +33,11 @@ _folders="3com acenic adaptec advansys amd-ucode amdgpu ar3k ath10k ath6k
r128 radeon rockchip rsi rtl8192e rtl_bt rtl_nic rtlwifi sb16 slicoss sun sxg
tehuti ti-connectivity ti-keystone tigon ttusb-budget ueagle-atm vicam vxge yam
yamaha"
-subpackages="$pkgname-other"
-depends="linux-firmware-other"
+subpackages="$pkgname-other $pkgname-none"
+depends="linux-firmware-other=$pkgver-r$pkgrel"
for i in $_folders; do
subpackages="$pkgname-$i:folder $subpackages"
- depends="$pkgname-$i $depends"
+ depends="$pkgname-$i=$pkgver-r$pkgrel $depends"
done
snapshot() {
@@ -68,6 +69,8 @@ folder() {
local folder=${subpkgname##linux-firmware-}
pkgdesc="firmware files for linux ($folder folder)"
depends=""
+ provides="linux-firmware-any"
+ provider_priority=
# Move /lib/firmware/$folder (case insensitive)
mkdir -p "$subpkgdir/lib/firmware"
@@ -94,10 +97,21 @@ other() {
# Move /lib/firmware (which doesn't have subfolders now)
pkgdesc="firmware files for linux (uncategorized)"
depends=""
+ provides="linux-firmware-any"
+ provider_priority=
mkdir -p "$subpkgdir"/
mv "$pkgdir"/lib "$subpkgdir"/
}
-sha512sums="05379d327e5f986607bbca87dc81eef4a3c894556854464f0134a52692116b161d68c41de9d838290c4bba617322ea7043aefe81ca457e52e57922f73210b2d7 linux-firmware-20180417.tar.gz
+none() {
+ # dummy package with no firmware
+ pkgdesc="Empty linux firwmare package for those who does not need any firmware"
+ provider_priority=
+ provides="linux-firmware-any"
+ mkdir -p "$subpkgdir"
+}
+
+
+sha512sums="37572701d6e7be63dfb026f8a23fee345da1e1b191f02cc80d5f323537d544b325d484517966226a6e87d9b3c3741311ad7c6f2b15253b0a88f6875794f8c824 linux-firmware-20180615.tar.gz
d3c9ae08bbb2323b4737d65a0416702c92eb52f9c395c8da6be00eb2f1d68efcb2dcb88e357adaf2130dafab32378b13d0a56c37bb647af145e5029e23744e08 brcmfmac43430-sdio.txt
6c60b5c6df7265b9daa5dad6e409ed27fa8f4d3b2e80500d5af73d47dba9d00b2e384f43f086cb3d6b594412463857733bce78af623c573a200308508321bb25 brcmfmac43430-sdio.bin"