aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-rpi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-24 16:15:53 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-24 16:16:13 +0200
commit5a4d9751ce0fe2df94ad4ba9008d56635f00b3f9 (patch)
tree8403b3b5d8b7da6b3e044d359d3bc4ff88a47ca0 /main/linux-rpi
parente2e363b34a1e410382f94126394735417ee899cc (diff)
downloadaports-5a4d9751ce0fe2df94ad4ba9008d56635f00b3f9.tar.bz2
aports-5a4d9751ce0fe2df94ad4ba9008d56635f00b3f9.tar.xz
main/linux-rpi: add -fno-pie, enable stack-protector
Diffstat (limited to 'main/linux-rpi')
-rw-r--r--main/linux-rpi/APKBUILD17
-rw-r--r--main/linux-rpi/config-rpi.armhf8
-rw-r--r--main/linux-rpi/config-rpi2.armhf8
3 files changed, 16 insertions, 17 deletions
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index 3f73a197af..1c83959406 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -6,7 +6,7 @@ case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with Raspberry Pi patches"
url=https://github.com/raspberrypi/linux
depends="mkinitfs linux-firmware"
@@ -91,10 +91,9 @@ prepare() {
}
build() {
- export GCC_SPECS=hardenednopie.specs
for i in $_flavors; do
cd "$srcdir"/build-$i
- make CC="${CC:-gcc}" \
+ make CC="${CC:-gcc} -fno-pie" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
done
@@ -202,8 +201,8 @@ md5sums="9a78fa2eb6c68ca5a40ed5af08142599 linux-4.4.tar.xz
b66e8aa4991ca5c2ccd61559ed7e6491 gpio-mcp23s08-pullups.patch
5508d2b3e5967bd57f92f551d90b3e54 rotary-encoder-fix.patch
29281b74d2cef6965fa4ab6d826a2aa4 issue-4973.patch
-9de1b6b237f27a5aefaf0ef185ca6130 config-rpi.armhf
-6896d8b5b42dda4d6d316bc584fd54ea config-rpi2.armhf
+1e8797d614a89984954523245ccbd237 config-rpi.armhf
+c188e45c15e82c57f0a624b415c73c46 config-rpi2.armhf
e587cae1dca2f5992555d9bcf53deecf markdt"
sha256sums="401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2 linux-4.4.tar.xz
b1e77807267aa3ec81e46c15b1a4be0c7169b6c19eb52cd371c4f58dd2183a9d patch-4.4.34.xz
@@ -212,8 +211,8 @@ b1e77807267aa3ec81e46c15b1a4be0c7169b6c19eb52cd371c4f58dd2183a9d patch-4.4.34.x
b389a556bbd98053881b43deef1adf20640f980557c5f37cfd7ece2daeecbda9 gpio-mcp23s08-pullups.patch
ab6740577fe8c1d71d2c716720ebbbf9a750985963d6938093b4ca9194b6e871 rotary-encoder-fix.patch
3a16e927ce53a8c56e7f1dd86fe8ad08b1c06466f5206c521a7e2de1e4796d6c issue-4973.patch
-9c756dc18ded9fc22169c8c590efc347d8e8fa02f4e55112cfb61257e81789eb config-rpi.armhf
-501ef2baa0ed0c1ead7a90d0ee91e6146ed67601819a26eb579a1794f7809ace config-rpi2.armhf
+86825369de54822d49aa4ea2f23822f6c29ba00baf8f41f6b983c8cc4ccfc765 config-rpi.armhf
+3f2b9916a143816f747f3c8fd1a117fba297df756258304215ae24da37860a09 config-rpi2.armhf
0f6681fc5c3590e1dbe13a2bde796403bd1529cf0fe19720899eaa0db79bcb49 markdt"
sha512sums="13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e linux-4.4.tar.xz
7d1d5eef1d5d722aa67b0a0438f6c5645e5fe93e6e1fa57a31c3889539472442c8ac8ebcbd49dff4a5c210e4fdcff3e021821dc8b52dbf17b2413512e08ba8e0 patch-4.4.34.xz
@@ -222,6 +221,6 @@ a00d5172b9075d36e72a1f80071221f39257eeb448a9692d22c6480c7d242de60520e1829eb06314
36724ba56cb8fdf3a3d347cffb67ae1cc3d7b1052d526b6b5134ebf6baae9f9724b586c97833453dc7697ab24699426f0749af78b6a80be36967a80033a0cf40 gpio-mcp23s08-pullups.patch
3a711e2cdb6c0ecaceb3755437d38626dec8403e8aa167a6e16f64d8a8b7cc5bdc7e04aa7c05938719ebc90e319ec4124ee2151a7855e7838ee143b62d140ad0 rotary-encoder-fix.patch
501c91bf2538a18102da59bbccc3097f9c3c90079acc0e946ff075074160c09b8a66934e5ce5470e170f0e4f93d114709a95230367426d0bb7ea02c4bdf4cc9b issue-4973.patch
-2de7168c227cb8b35c2a3a0507384867fb98e7daa319393eed57bea799b151ce136bab1c5965393047aa79441fbb37d21ed41bdb844ecbc51321b736464a0343 config-rpi.armhf
-1729e96596e4bb792f57643b39cef35a23c96731ce084295cc4f47783654345d7a82da4770f9aba239bf2c82dbf082f4ee693da475b22d610ace0fa41f0fabe3 config-rpi2.armhf
+1c543ca5d08df99c1249fe8beb69b42eb3c985cd36b568cc6b0fa5b56951f702c790e6d2c2e51e46173179eb6cb39ee13fa8314a7277a55589bd9ccdd826c88f config-rpi.armhf
+3fe9eb7090e9e2794c36e057796e88bf9c138cc0cd2e3fd7a8e466f683ff9c38102dec8ed0cfb9e0b17a999490212ec14762d549ebc1ca7179d7efa86fec50d7 config-rpi2.armhf
a4ecd1f48db64f9d6a189250d1937d7f2cd3a049a3d24cc527d04d05db06137722f1ba44bcd6033794781c3f2cfe2fbe065410a16de4bfdf4b1cd95d89322a77 markdt"
diff --git a/main/linux-rpi/config-rpi.armhf b/main/linux-rpi/config-rpi.armhf
index ba77505b96..758b1e1085 100644
--- a/main/linux-rpi/config-rpi.armhf
+++ b/main/linux-rpi/config-rpi.armhf
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.4.32 Kernel Configuration
+# Linux/arm 4.4.34 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -223,10 +223,10 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
CONFIG_SECCOMP_FILTER=y
CONFIG_HAVE_CC_STACKPROTECTOR=y
-# CONFIG_CC_STACKPROTECTOR is not set
-CONFIG_CC_STACKPROTECTOR_NONE=y
+CONFIG_CC_STACKPROTECTOR=y
+# CONFIG_CC_STACKPROTECTOR_NONE is not set
# CONFIG_CC_STACKPROTECTOR_REGULAR is not set
-# CONFIG_CC_STACKPROTECTOR_STRONG is not set
+CONFIG_CC_STACKPROTECTOR_STRONG=y
CONFIG_HAVE_CONTEXT_TRACKING=y
CONFIG_HAVE_VIRT_CPU_ACCOUNTING_GEN=y
CONFIG_HAVE_IRQ_TIME_ACCOUNTING=y
diff --git a/main/linux-rpi/config-rpi2.armhf b/main/linux-rpi/config-rpi2.armhf
index 214309d671..802a41b5b4 100644
--- a/main/linux-rpi/config-rpi2.armhf
+++ b/main/linux-rpi/config-rpi2.armhf
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.4.32 Kernel Configuration
+# Linux/arm 4.4.34 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -227,10 +227,10 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
CONFIG_SECCOMP_FILTER=y
CONFIG_HAVE_CC_STACKPROTECTOR=y
-# CONFIG_CC_STACKPROTECTOR is not set
-CONFIG_CC_STACKPROTECTOR_NONE=y
+CONFIG_CC_STACKPROTECTOR=y
+# CONFIG_CC_STACKPROTECTOR_NONE is not set
# CONFIG_CC_STACKPROTECTOR_REGULAR is not set
-# CONFIG_CC_STACKPROTECTOR_STRONG is not set
+CONFIG_CC_STACKPROTECTOR_STRONG=y
CONFIG_HAVE_CONTEXT_TRACKING=y
CONFIG_HAVE_VIRT_CPU_ACCOUNTING_GEN=y
CONFIG_HAVE_IRQ_TIME_ACCOUNTING=y