aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-rpi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-06-17 08:25:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-06-17 13:32:55 +0000
commitf8a26e23fbb1e2aba3b77c6a449812e002b20f3f (patch)
treef25e7534797588dfb3f18904888d76a6202014ee /main/linux-rpi
parent93cbd0a2fc0c977b017af593bb72dcff8a5fd219 (diff)
downloadaports-f8a26e23fbb1e2aba3b77c6a449812e002b20f3f.tar.bz2
aports-f8a26e23fbb1e2aba3b77c6a449812e002b20f3f.tar.xz
main/linux-rpi: upgrade to 4.4.13, new rpi patches, fix dtb install
fixes #5729
Diffstat (limited to 'main/linux-rpi')
-rw-r--r--main/linux-rpi/APKBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index 2357adbba0..8e053befe0 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=linux-rpi
-pkgver=4.4.12
+pkgver=4.4.13
case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
esac
-pkgrel=1
+pkgrel=0
pkgdesc="Linux kernel with Raspberry Pi patches"
url=https://github.com/raspberrypi/linux
depends="mkinitfs linux-firmware"
@@ -15,8 +15,8 @@ options="!strip"
install=
source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
http://ftp.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
- http://dev.alpinelinux.org/~tteras/rpi/linux-4.4.y-rpi-20160602.patch
- http://dev.alpinelinux.org/~tteras/rpi/rpi-cirrus-4.4.y-20160602.patch
+ http://dev.alpinelinux.org/~tteras/rpi/linux-4.4.y-rpi-20160617.patch
+ http://dev.alpinelinux.org/~tteras/rpi/rpi-cirrus-4.4.y-20160617.patch
gpio-mcp23s08-pullups.patch
rotary-encoder-fix.patch
issue-4973.patch
@@ -108,11 +108,7 @@ _package() {
local _install
case "$CARCH" in
arm*)
- local _dtbdir="$_outdir"/usr/lib/linux-${_abi_release}
- cd "$srcdir"/build-$_buildflavor/arch/arm/boot/dts || return 1
- mkdir -p "$_dtbdir"
- find . -name "*.dtb" -type f | cpio -pdm "$_dtbdir"
- _install=zinstall
+ _install="zinstall dtbs_install"
;;
*)
_install=install
@@ -123,6 +119,7 @@ _package() {
make -j1 modules_install firmware_install $_install \
INSTALL_MOD_PATH="$_outdir" \
INSTALL_PATH="$_outdir"/boot \
+ INSTALL_DTBS_PATH="$_outdir"/usr/lib/linux-${_abi_release} \
|| return 1
# tell rpi bootloader we are device tree capable
@@ -196,9 +193,9 @@ for _f in $_flavors; do
done
md5sums="9a78fa2eb6c68ca5a40ed5af08142599 linux-4.4.tar.xz
-80d71a51152029a3f2fe99ba94548009 patch-4.4.12.xz
-1609c27d419440bc5eb338feffa4ab9d linux-4.4.y-rpi-20160602.patch
-f7142b2154dd5cfb5688ba692195ef6f rpi-cirrus-4.4.y-20160602.patch
+0985afde06951614f594120d7c8ffad7 patch-4.4.13.xz
+09f58bd0c24b5b7366122a2a0357f905 linux-4.4.y-rpi-20160617.patch
+9ae99227aab1aaf06c1f8a9f35ccadb0 rpi-cirrus-4.4.y-20160617.patch
b66e8aa4991ca5c2ccd61559ed7e6491 gpio-mcp23s08-pullups.patch
5508d2b3e5967bd57f92f551d90b3e54 rotary-encoder-fix.patch
29281b74d2cef6965fa4ab6d826a2aa4 issue-4973.patch
@@ -206,9 +203,9 @@ a58b771ccb44b8ca3d742723652cfe5c config-rpi.armhf
92897d5e23fe720790866e939ae1ed71 config-rpi2.armhf
e587cae1dca2f5992555d9bcf53deecf markdt"
sha256sums="401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2 linux-4.4.tar.xz
-1eb89dddd7e89caf2df17470b4b15da451ef1aa97f8e1a88578a8ee2da75729a patch-4.4.12.xz
-f05f9cb93a6445b07231afd4ac1052ca572bf7441c7d5c073edc2c99a28af096 linux-4.4.y-rpi-20160602.patch
-2e108a1d5e261e9193a2999afafef41e04e274db4c43607a1164d03d744c1e8e rpi-cirrus-4.4.y-20160602.patch
+be42ec5fecf89c6f730f4d7af7db1dac56ac8f6451aed9246a500302ad8f3899 patch-4.4.13.xz
+3c88b7df0f122e04c62ce12ba5d3313e23a877387f1403e3b02e5193b6669be0 linux-4.4.y-rpi-20160617.patch
+52bfeefa4025a99dd2cf123fb5ca5c5ddbc2f8a4240535b091c6e41b25b14628 rpi-cirrus-4.4.y-20160617.patch
b389a556bbd98053881b43deef1adf20640f980557c5f37cfd7ece2daeecbda9 gpio-mcp23s08-pullups.patch
ab6740577fe8c1d71d2c716720ebbbf9a750985963d6938093b4ca9194b6e871 rotary-encoder-fix.patch
3a16e927ce53a8c56e7f1dd86fe8ad08b1c06466f5206c521a7e2de1e4796d6c issue-4973.patch
@@ -216,9 +213,9 @@ a27f0042e2bd4fda9ed08552b05c747c061ffec17268d58012e32364cd7c12eb config-rpi.arm
f372f254bf021160d8091512c714f0ec0bb2cc46baf5c98d6270b15e9b725511 config-rpi2.armhf
0f6681fc5c3590e1dbe13a2bde796403bd1529cf0fe19720899eaa0db79bcb49 markdt"
sha512sums="13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e linux-4.4.tar.xz
-c3aca55f26fc883b489635a90b79c03d7c6d591efddb4e406b5bfe49fc4326ff2a957521b1d8ea126b95f1d0573e5185d96bce10d05eae595a51f8eb27690404 patch-4.4.12.xz
-bb7bde9521281e5507bf0b0ed8912f56bd374df908f7f5f348a2faf223f3b92702988bdd07d0515aa90b4b03630de0edba598b3ebe49653483992828eea59e2b linux-4.4.y-rpi-20160602.patch
-9313a0553eee9d21efc019444273a4f6359afa6efaf12f1a65876f0fec43358e0a82ac851c6b830e28f8ae7f30e803949dcc40bcab43d57b3c50234fad2e621a rpi-cirrus-4.4.y-20160602.patch
+f79c1eb5847f2bffd742f7fec65be11caa5158dabb28e5b90737bb82d3b254466bc3e58d7884d2df461d46e6c6b909c8ad088d911cabd0a14c70627f6570e7d3 patch-4.4.13.xz
+e486c0aa2348879de8a311165908f378d83ca185b4109bcca8d4233314285a138aaee70229861e1a14864ab0964c6fb4fcf465b763b33c9addf80ec06ad45cdc linux-4.4.y-rpi-20160617.patch
+88a98c21065d6972c862473f6666a546bd088006d766173b9b28ff7e0060adc5dff984b504b35b2f2d2c917270979376e821bf06606444e4df1c9dc7dba3e01e rpi-cirrus-4.4.y-20160617.patch
36724ba56cb8fdf3a3d347cffb67ae1cc3d7b1052d526b6b5134ebf6baae9f9724b586c97833453dc7697ab24699426f0749af78b6a80be36967a80033a0cf40 gpio-mcp23s08-pullups.patch
3a711e2cdb6c0ecaceb3755437d38626dec8403e8aa167a6e16f64d8a8b7cc5bdc7e04aa7c05938719ebc90e319ec4124ee2151a7855e7838ee143b62d140ad0 rotary-encoder-fix.patch
501c91bf2538a18102da59bbccc3097f9c3c90079acc0e946ff075074160c09b8a66934e5ce5470e170f0e4f93d114709a95230367426d0bb7ea02c4bdf4cc9b issue-4973.patch