aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-struct
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-17 08:58:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-17 08:58:50 +0000
commit3fc6ec8458cc9489822debf2f095b915cc9dcf4c (patch)
tree1f426f7824301b748f0ba5ec5f3dc23c8e2ee075 /main/lua-struct
parent4572b9e0de756fca391d855fd418bf6c744217f2 (diff)
downloadaports-3fc6ec8458cc9489822debf2f095b915cc9dcf4c.tar.bz2
aports-3fc6ec8458cc9489822debf2f095b915cc9dcf4c.tar.xz
main/lua-struct: move from testing
Diffstat (limited to 'main/lua-struct')
-rw-r--r--main/lua-struct/APKBUILD74
-rw-r--r--main/lua-struct/makefile.patch22
2 files changed, 96 insertions, 0 deletions
diff --git a/main/lua-struct/APKBUILD b/main/lua-struct/APKBUILD
new file mode 100644
index 0000000000..2f6b2b1e7d
--- /dev/null
+++ b/main/lua-struct/APKBUILD
@@ -0,0 +1,74 @@
+# Maintailer: Natanael Copa <ncopa@alpinelinux.org>
+
+_luaversions="5.1 5.2"
+
+pkgname=lua-struct
+pkgver=0.2
+pkgrel=1
+pkgdesc="Library for Converting Data to and from C Structs for Lua"
+url="http://www.inf.puc-rio.br/~roberto/struct/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://www.inf.puc-rio.br/~roberto/struct/struct-$pkgver.tar.gz
+ makefile.patch
+ "
+
+for _i in $_luaversions; do
+ depends="$depends lua$_i-struct"
+ makedepends="$makedepends lua$_i-dev"
+ subpackages="$subpackages lua$_i-struct:_split${_i/./}"
+done
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ for i in $_luaversions; do
+ mkdir $i
+ cp makefile *.c $i/
+ done
+}
+
+build() {
+ for i in $_luaversions; do
+ cd "$_builddir"/$i
+ make OPT_CFLAGS="$CFLAGS" LUAPC="lua$i" || return 1
+ done
+
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"
+}
+
+_split() {
+ local _v=$1
+ pkgdesc="$pkgdesc - Lua $_v"
+ depends=
+ mkdir -p "$subpkgdir"/usr/lib/lua/$_v
+ install "$srcdir"/$_v/struct.so "$subpkgdir"/usr/lib/lua/$_v/struct.so \
+ || return 1
+}
+
+for _i in $_luaversions; do
+ eval "_split${_i/./}() { _split $_i; }"
+done
+
+
+md5sums="99384bf1f54457ec9f796ad0b539d19c struct-0.2.tar.gz
+45b8350d44a99d65ac7c1d2c33abd975 makefile.patch"
+sha256sums="c71d1f9f9f74ac74a973f75961285651200daf53dcb4316f23ba7bea6817a7a5 struct-0.2.tar.gz
+415cf549e0587252ab387f2ca624d2b17f511499908873b08774057e21da1b60 makefile.patch"
+sha512sums="6fea0bb2c04cdc47d402e0c8604bc78d9a68ec60f6d521ce031e4f9ede42fd2e2081f6732d74f2745883ad13bdef9f08fa4db5c0053fdc3204e2938dc01ea328 struct-0.2.tar.gz
+444ca21864ec92dde759f0f8f5d9990d029e9dbb1df908b092360b2eb9633c64079aff55ae91a4ea4de4c27a89243db195c2f460a03193e8c493c507387a1501 makefile.patch"
diff --git a/main/lua-struct/makefile.patch b/main/lua-struct/makefile.patch
new file mode 100644
index 0000000000..9d3867fe1c
--- /dev/null
+++ b/main/lua-struct/makefile.patch
@@ -0,0 +1,22 @@
+--- ./makefile.orig
++++ ./makefile
+@@ -1,6 +1,5 @@
+-# point it to where the compiler can find the Lua header files (lua.h, etc.)
+-# LUADIR = ../lua
+-LUADIR = /usr/include/lua5.1/
++LUAPC?=lua5.1
++LUA_CFLAGS = $(shell pkg-config --cflags $(LUAPC))
+
+ # define your own "large" integer type; not defining a proper type
+ # will default to 'long', which may cause problems with 'size_t'
+@@ -16,8 +15,8 @@
+ -Wshadow \
+ -Wwrite-strings
+
+-CFLAGS = -D_POSIX_SOURCE $(CWARNS) $(INTTYPE) -O2 -I$(LUADIR)
+-CC = gcc
++OPT_CFLAGS ?= -O2
++CFLAGS = -D_POSIX_SOURCE $(CWARNS) $(INTTYPE) $(OPT_CFLAGS) $(LUA_CFLAGS)
+
+ struct.so: struct.c makefile
+ $(CC) $(CFLAGS) -shared -fpic -o struct.so struct.c