aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-struct
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-06 12:03:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-06 12:03:46 +0000
commitfa7eabbbe240ffe36eaab70f32f21602be3f3cf1 (patch)
tree69f92feea6c65ea549f54cad231bd55a8d58793b /main/lua-struct
parent1f9c7982d550a5228dbc379c87b26ed43e25c229 (diff)
downloadaports-fa7eabbbe240ffe36eaab70f32f21602be3f3cf1.tar.bz2
aports-fa7eabbbe240ffe36eaab70f32f21602be3f3cf1.tar.xz
main/lua-struct: add lua 5.3 and use install_if
Diffstat (limited to 'main/lua-struct')
-rw-r--r--main/lua-struct/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/lua-struct/APKBUILD b/main/lua-struct/APKBUILD
index 2f6b2b1e7d..2f7c4a6035 100644
--- a/main/lua-struct/APKBUILD
+++ b/main/lua-struct/APKBUILD
@@ -1,10 +1,10 @@
# Maintailer: Natanael Copa <ncopa@alpinelinux.org>
-_luaversions="5.1 5.2"
+_luaversions="5.1 5.2 5.3"
pkgname=lua-struct
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Library for Converting Data to and from C Structs for Lua"
url="http://www.inf.puc-rio.br/~roberto/struct/"
arch="all"
@@ -19,7 +19,6 @@ source="http://www.inf.puc-rio.br/~roberto/struct/struct-$pkgver.tar.gz
"
for _i in $_luaversions; do
- depends="$depends lua$_i-struct"
makedepends="$makedepends lua$_i-dev"
subpackages="$subpackages lua$_i-struct:_split${_i/./}"
done
@@ -42,7 +41,7 @@ prepare() {
build() {
for i in $_luaversions; do
cd "$_builddir"/$i
- make OPT_CFLAGS="$CFLAGS" LUAPC="lua$i" || return 1
+ make OPT_CFLAGS="$CFLAGS -std=c99" LUAPC="lua$i" || return 1
done
}
@@ -55,6 +54,7 @@ package() {
_split() {
local _v=$1
pkgdesc="$pkgdesc - Lua $_v"
+ install_if="lua$_v $pkgname=$pkgver-r$pkgrel"
depends=
mkdir -p "$subpkgdir"/usr/lib/lua/$_v
install "$srcdir"/$_v/struct.so "$subpkgdir"/usr/lib/lua/$_v/struct.so \