aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua5.1/lua-5.1-make.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-27 08:13:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-27 08:14:22 +0000
commit8a8d04916305d3f9109c3fe93a028d3113d4aa4f (patch)
tree56a1e7228478a38e2b683864dbfdb48b61e43e05 /main/lua5.1/lua-5.1-make.patch
parent7c2a2e0722a11b7b5aa8c530025854a1c2f3be29 (diff)
downloadaports-8a8d04916305d3f9109c3fe93a028d3113d4aa4f.tar.bz2
aports-8a8d04916305d3f9109c3fe93a028d3113d4aa4f.tar.xz
main/lua5.1: fixes for newer libtool
Diffstat (limited to 'main/lua5.1/lua-5.1-make.patch')
-rw-r--r--main/lua5.1/lua-5.1-make.patch69
1 files changed, 38 insertions, 31 deletions
diff --git a/main/lua5.1/lua-5.1-make.patch b/main/lua5.1/lua-5.1-make.patch
index d051a21cb6..2db6367a3e 100644
--- a/main/lua5.1/lua-5.1-make.patch
+++ b/main/lua5.1/lua-5.1-make.patch
@@ -1,37 +1,47 @@
---- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
-+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
-@@ -127,3 +127,22 @@
- .PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho newer
+--- ./Makefile.orig
++++ ./Makefile
+@@ -126,3 +126,18 @@
+ .PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho
# (end of Makefile)
+
+# Use libtool for binary installs, etc.
+
+export V
-+export LIBTOOL = libtool --quiet --tag=CC
++export LIBTOOL = ../libtool --quiet --tag=CC
+# See libtool manual about how to set this
+
-+gentoo_clean:
++alpine_clean:
+ cd src; $(MAKE) $@
+
-+gentoo_test: gentoo_linux
-+ test/lua.static test/hello.lua
-+
-+gentoo_install:
++alpine_install:
+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.a $(INSTALL_LIB)
---- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
-+++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
-@@ -176,3 +176,36 @@
- ltm.h lzio.h lmem.h lopcodes.h lundump.h
+--- ./src/Makefile.orig
++++ ./src/Makefile
+@@ -51,10 +51,10 @@
+ $(AR) $@ $(CORE_O) $(LIB_O) # DLL needs all object files
+ $(RANLIB) $@
- # (end of Makefile)
+-$(LUA_T): $(LUA_O) $(LUA_A)
++origin$(LUA_T): $(LUA_O) $(LUA_A)
+ $(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+
+-$(LUAC_T): $(LUAC_O) $(LUA_A)
++origin$(LUAC_T): $(LUAC_O) $(LUA_A)
+ $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
+
+ clean:
+@@ -178,5 +178,34 @@
+ lzio.h
+ print.o: print.c ldebug.h lstate.h lua.h luaconf.h lobject.h llimits.h \
+ ltm.h lzio.h lmem.h lopcodes.h lundump.h
+
-+export LIBTOOL = libtool --quiet --tag=CC
-+export LIB_VERSION = 6:1:1
++
++export LIBTOOL = ../libtool --quiet --tag=CC
++export LIB_VERSION = 0:0:0
+
+# The following rules use libtool for compiling and linking in order to
+# provide shared library support.
@@ -44,21 +54,18 @@
+
+$(LIB_NAME): $(LIB_OBJS)
+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
-+ -rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
-+
-+$(LIB_NAME:.la=.a): $(LIB_OBJS)
-+ $(LIBTOOL) --mode=link $(CC) -static -o $(LIB_NAME:.la=.a) $(LIB_OBJS)
-+
-+$(LUA_T): $(LUA_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
++ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
+
-+lua_test: $(LUA_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
++$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
++ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
+
-+$(LUAC_T): $(LUAC_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)
++$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
++ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O:.o=.lo) $(LIB_NAME)
+
-+gentoo_clean:
++alpine_clean:
+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
+
-+gentoo_all: $(LIB_NAME) $(LIB_NAME:.la=.a) $(LUA_T) lua_test $(LUAC_T)
++alpine_all: $(LIB_NAME) $(LUA_T) $(LUAC_T)
++
+
+ # (end of Makefile)