aboutsummaryrefslogtreecommitdiffstats
path: root/main/mdds
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-10 14:50:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-10 14:59:57 +0000
commit3bb9083f6470b3fe3dbb9704b1d1d7ecbaa2de16 (patch)
tree13b6f9813a18f5840c040b6a3f17dd78a65551d6 /main/mdds
parent3969d3a066305d1d0f3da7c44a6e20878740ea9a (diff)
downloadaports-3bb9083f6470b3fe3dbb9704b1d1d7ecbaa2de16.tar.bz2
aports-3bb9083f6470b3fe3dbb9704b1d1d7ecbaa2de16.tar.xz
main/mdds: moved to main
Diffstat (limited to 'main/mdds')
-rw-r--r--main/mdds/APKBUILD54
-rw-r--r--main/mdds/fix-includes.patch22
2 files changed, 76 insertions, 0 deletions
diff --git a/main/mdds/APKBUILD b/main/mdds/APKBUILD
new file mode 100644
index 0000000000..7d7ddd781d
--- /dev/null
+++ b/main/mdds/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=mdds
+pkgver=0.11.2
+pkgrel=0
+pkgdesc="Multi-dimentional data index algorithm"
+url="https://code.google.com/p/multidimalgorithm/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://kohei.us/files/$pkgname/src/${pkgname}_$pkgver.tar.bz2
+ fix-includes.patch"
+
+_builddir="$srcdir"/${pkgname}_$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="cb4207cb913c7a5a8bfa5b91234618ee mdds_0.11.2.tar.bz2
+4d66429cefdfe7148c08ccf215456e5d fix-includes.patch"
+sha256sums="cd0a0dc8b35d6582efad6898546c86714eb058696ba26b0e7f8914faa002a5ab mdds_0.11.2.tar.bz2
+ad7d70674b1c43d40424d6ba516a9b1e36c0d1b6cf3f4c2c5a8c6363ada64480 fix-includes.patch"
+sha512sums="b0e00d50be9b8319dabfe7e607849af27a52be9b46d770849b919444b905bf198d99edcefe1be15e6018b79839443b3a709fe22b84ac11e2267f02bec5139633 mdds_0.11.2.tar.bz2
+abee8e19967c79a079122af29c7caa2da44a8ac5c6adf1b3a4aff3d2d68dc5ad428f4597234244842908225c97a978a4bf949208512b7c42067ae5690ef7624d fix-includes.patch"
diff --git a/main/mdds/fix-includes.patch b/main/mdds/fix-includes.patch
new file mode 100644
index 0000000000..c5a1b4e864
--- /dev/null
+++ b/main/mdds/fix-includes.patch
@@ -0,0 +1,22 @@
+https://code.google.com/p/multidimalgorithm/source/detail?r=c45e0499dded11dc2aacea40b470ab1431ea535a
+
+diff -ru mdds_0.11.2.orig/include/mdds/multi_type_vector_types.hpp mdds_0.11.2/include/mdds/multi_type_vector_types.hpp
+--- mdds_0.11.2.orig/include/mdds/multi_type_vector_types.hpp 2014-12-18 20:05:56.187026008 +0000
++++ mdds_0.11.2/include/mdds/multi_type_vector_types.hpp 2015-02-03 12:36:08.172570111 +0000
+@@ -32,6 +32,8 @@
+ #include "compat/unique_ptr.hpp"
+ #include "global.hpp"
+
++#include <algorithm>
++
+ #ifdef MDDS_MULTI_TYPE_VECTOR_USE_DEQUE
+ #include <deque>
+ #else
+@@ -40,7 +42,6 @@
+ #include <boost/noncopyable.hpp>
+
+ #if defined(MDDS_UNIT_TEST) || defined (MDDS_MULTI_TYPE_VECTOR_DEBUG)
+-#include <algorithm>
+ #include <iostream>
+ #include <sstream>
+ using std::cout;