aboutsummaryrefslogtreecommitdiffstats
path: root/main/mini_httpd
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-07-31 21:32:24 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-08-02 05:45:05 +0000
commitec8202429cd4b2f5e21499ece428c334a9af449a (patch)
treea852320360617e47d53974e185b34b9ccc0d66d7 /main/mini_httpd
parent6fd7e86b311ce75083b61dd25f2577ef4461a8f4 (diff)
downloadaports-ec8202429cd4b2f5e21499ece428c334a9af449a.tar.bz2
aports-ec8202429cd4b2f5e21499ece428c334a9af449a.tar.xz
main/mini_httpd: upgrade to 1.27
Diffstat (limited to 'main/mini_httpd')
-rw-r--r--main/mini_httpd/APKBUILD11
-rw-r--r--main/mini_httpd/fix-cgi.patch28
2 files changed, 4 insertions, 35 deletions
diff --git a/main/mini_httpd/APKBUILD b/main/mini_httpd/APKBUILD
index af4384b2a6..cc86aafd1c 100644
--- a/main/mini_httpd/APKBUILD
+++ b/main/mini_httpd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mini_httpd
-pkgver=1.26
-pkgrel=2
+pkgver=1.27
+pkgrel=0
pkgdesc="Small forking webserver with ssl and ipv6 support"
url="http://www.acme.com/software/mini_httpd/"
arch="all"
@@ -13,7 +13,6 @@ makedepends="libressl-dev"
subpackages="$pkgname-doc"
install="$pkgname.pre-install"
source="http://www.acme.com/software/$pkgname/$pkgname-$pkgver.tar.gz
- fix-cgi.patch
$pkgname.conf
$pkgname.initd
$pkgname.logrotate
@@ -24,8 +23,7 @@ build() {
cd "$builddir"
make CFLAGS="${CFLAGS} -DUSE_SSL" \
LDFLAGS="${LDFLAGS}" \
- SSL_LIBS="-lssl -lcrypto" \
- || return 1
+ SSL_LIBS="-lssl -lcrypto"
}
package() {
@@ -50,8 +48,7 @@ package() {
install -dm755 -g $pkggroups "$pkgdir"/var/www/localhost/htdocs
}
-sha512sums="d29027df1c5cc3b4f4c91915a729337028372374042d663431e7f0ca0e6bd5b3d1cf1658cc6d2e6f5fa576268e06b81a12fc7b954ccb779645d267c5b180e3e3 mini_httpd-1.26.tar.gz
-0ba18ce425ceb3f9fb18eeec7be2453263d76f81dfcc357fb8bd9d31bd89af69b030fa4d82bfe48441e81625a211e372aa06facd8fccacd5c0f33269a77de71f fix-cgi.patch
+sha512sums="a7374374d70eb6e531225bf944d80158c7a1870f0e9d3ab720f83706f722eaeac3a891f06c3d6ac2189e1d368504db0ce512440a1d09be109f804c8a0c7901e1 mini_httpd-1.27.tar.gz
1e6ef2da61c82ff5e8bb79058c188954d72c69e9d25abdd9bca51f3122aac8729bcfd6e53ae7ee40807b9250698f2cde13dad51ffed962aa07004c7f456f9cb3 mini_httpd.conf
9daa9052609136a461c912ee2b64829abf2c4c626553a12a3d45c2158be4ed0749126b5ea594fed02a6a4779d7869a073070c259ac28ca19171a168fcbb0632c mini_httpd.initd
701c8d393963836267289cba7352caaf61925c6a7e4903f0d418245415b214e17dcab3497697dd5c9ab80f3f71c9cb5dbcc0a3706bc6be25b6031da000ee0ef0 mini_httpd.logrotate"
diff --git a/main/mini_httpd/fix-cgi.patch b/main/mini_httpd/fix-cgi.patch
deleted file mode 100644
index a2ab935d3d..0000000000
--- a/main/mini_httpd/fix-cgi.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-The headers buffer contains also potentially binary data the CGI program is
-sending, and it needs to be sent out later. Use add_data() to cache data so
-the cgi output does not get corrupted on first zero byte. add_data() still
-always terminates the buffer with zero, so strstr() can used safely.
-
-diff -ru mini_httpd-1.25.orig/mini_httpd.c mini_httpd-1.25/mini_httpd.c
---- mini_httpd-1.25.orig/mini_httpd.c 2016-07-07 06:02:52.000000000 +0300
-+++ mini_httpd-1.25/mini_httpd.c 2016-11-09 12:01:19.025607907 +0200
-@@ -1998,7 +1998,7 @@
- add_str( &headers, &headers_size, &headers_len, (char*) 0 );
- for (;;)
- {
-- r = read( rfd, buf, sizeof(buf) - 1 );
-+ r = read( rfd, buf, sizeof(buf) );
- if ( r < 0 && ( errno == EINTR || errno == EAGAIN ) )
- {
- sleep( 1 );
-@@ -2009,8 +2009,7 @@
- br = &(headers[headers_len]);
- break;
- }
-- buf[r] = '\0';
-- add_str( &headers, &headers_size, &headers_len, buf );
-+ add_data( &headers, &headers_size, &headers_len, buf, r );
- if ( ( br = strstr( headers, "\015\012\015\012" ) ) != (char*) 0 ||
- ( br = strstr( headers, "\012\012" ) ) != (char*) 0 )
- break;
-