aboutsummaryrefslogtreecommitdiffstats
path: root/main/mkinitfs
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-01-20 01:00:48 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-01-24 20:26:12 +0100
commit4fae883870e8503a4f83bc718b26d3258b224b9e (patch)
tree306e040ac93f97f1aa74f056deb7ce54282e7ad7 /main/mkinitfs
parent6f13e59b1dd3f29b18acdbb5b6ee49743cd0b2c1 (diff)
downloadaports-4fae883870e8503a4f83bc718b26d3258b224b9e.tar.bz2
aports-4fae883870e8503a4f83bc718b26d3258b224b9e.tar.xz
main/mkinitfs: backport patch for LUKS2 support
Diffstat (limited to 'main/mkinitfs')
-rw-r--r--main/mkinitfs/0001-nlplug-findfs-add-primitive-support-for-LUKS2-contai.patch31
-rw-r--r--main/mkinitfs/APKBUILD6
2 files changed, 35 insertions, 2 deletions
diff --git a/main/mkinitfs/0001-nlplug-findfs-add-primitive-support-for-LUKS2-contai.patch b/main/mkinitfs/0001-nlplug-findfs-add-primitive-support-for-LUKS2-contai.patch
new file mode 100644
index 0000000000..7681be46b3
--- /dev/null
+++ b/main/mkinitfs/0001-nlplug-findfs-add-primitive-support-for-LUKS2-contai.patch
@@ -0,0 +1,31 @@
+From 15e312961e1bc86da98f2d3dc1d43331bd6f98f7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Sat, 20 Jan 2018 00:50:15 +0100
+Subject: [PATCH] nlplug-findfs: add primitive support for LUKS2 containers
+
+Since we previously specified an explicit request_type for the
+crypt_load() function nlplug-findfs couldn't open LUKS2 containers. By
+using CRYPT_LUKS crypt_load accepts any known LUKUS container format.
+
+We could add an additional command line flag to nlplug-finds for
+specifying the request_type but I guess this is good enough for now.
+---
+ nlplug-findfs.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nlplug-findfs.c b/nlplug-findfs.c
+index be525cc..7fb5468 100644
+--- a/nlplug-findfs.c
++++ b/nlplug-findfs.c
+@@ -582,7 +582,7 @@ static void *cryptsetup_thread(void *data)
+ goto notify_out;
+ }
+
+- r = crypt_load(cd, CRYPT_LUKS1, params);
++ r = crypt_load(cd, CRYPT_LUKS, params);
+ if (r < 0) {
+ warnx("crypt_load(%s)", data_devnode);
+ goto free_out;
+--
+2.15.0
+
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 6de7892117..e5873de2c4 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mkinitfs
pkgver=3.2.0
_ver=${pkgver%_git*}
-pkgrel=2
+pkgrel=3
pkgdesc="Tool to generate initramfs images for Alpine"
url="https://git.alpinelinux.org/cgit/mkinitfs"
arch="all"
@@ -15,6 +15,7 @@ install="$pkgname.pre-upgrade $pkgname.post-install $pkgname.post-upgrade"
triggers="$pkgname.trigger=/usr/share/kernel/*"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz
0001-skip-hooks-on-diskless-install.patch
+ 0001-nlplug-findfs-add-primitive-support-for-LUKS2-contai.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -29,4 +30,5 @@ package() {
}
sha512sums="906bfbce677d4ece9c9fea7b2a529121740bc9d96ea011be083303cc5c56162f09271b0a673e9e335234ccf2f293109bda1eda333698a95357d0772c86f498af mkinitfs-3.2.0.tar.xz
-f5c9b21e53c663dac1b8f33f929dbe067492f0dc1bd5ef5310ef531033f31fc3fa0b6de6dce03cecaf90b8ed47b278d0f1f7c64dbbeede7621c895ee3ea79864 0001-skip-hooks-on-diskless-install.patch"
+f5c9b21e53c663dac1b8f33f929dbe067492f0dc1bd5ef5310ef531033f31fc3fa0b6de6dce03cecaf90b8ed47b278d0f1f7c64dbbeede7621c895ee3ea79864 0001-skip-hooks-on-diskless-install.patch
+4d298d73cc6e557c51de805721ef4b9f002498af5dd9f0aebfd6620ec84d1fadde76888bc2d40efc71dc0a8497aa0586ac65d596eb0021bfed633adcc3aca3b4 0001-nlplug-findfs-add-primitive-support-for-LUKS2-contai.patch"