aboutsummaryrefslogtreecommitdiffstats
path: root/main/mkinitfs
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-03-21 11:47:23 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-03-21 11:47:23 +0200
commit7140f9c231b307186dd41214a7cf4e7299f1c82d (patch)
tree0f03c753d780ed3784cabd47e890c7a1972f6e09 /main/mkinitfs
parent386fc5d67c16d134b15a563cc45f01b08c1df8b4 (diff)
downloadaports-7140f9c231b307186dd41214a7cf4e7299f1c82d.tar.bz2
aports-7140f9c231b307186dd41214a7cf4e7299f1c82d.tar.xz
main/mkinitfs: fix cold plugging of certain platform/usb devices
Diffstat (limited to 'main/mkinitfs')
-rw-r--r--main/mkinitfs/0001-nlplug-findfs-increase-the-sys-recursion-limit.patch30
-rw-r--r--main/mkinitfs/APKBUILD12
2 files changed, 38 insertions, 4 deletions
diff --git a/main/mkinitfs/0001-nlplug-findfs-increase-the-sys-recursion-limit.patch b/main/mkinitfs/0001-nlplug-findfs-increase-the-sys-recursion-limit.patch
new file mode 100644
index 0000000000..f1e58f6f1a
--- /dev/null
+++ b/main/mkinitfs/0001-nlplug-findfs-increase-the-sys-recursion-limit.patch
@@ -0,0 +1,30 @@
+From b7b285ee9e05102f770d41643e5534bade289a58 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Mon, 21 Mar 2016 11:31:18 +0200
+Subject: [PATCH] nlplug-findfs: increase the /sys recursion limit
+
+certain platform and usb devices expose things deep down the tree,
+increase the recursion limit
+---
+ nlplug-findfs.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/nlplug-findfs.c b/nlplug-findfs.c
+index 5bdb7b1..b11b7b8 100644
+--- a/nlplug-findfs.c
++++ b/nlplug-findfs.c
+@@ -805,9 +805,9 @@ static void *trigger_thread(void *data)
+ };
+ char path[PATH_MAX] = "/sys/bus";
+
+- recurse_dir(path, &opts, 8);
++ recurse_dir(path, &opts, 64);
+ strcpy(path, "/sys/devices");
+- recurse_dir(path, &opts, 8);
++ recurse_dir(path, &opts, 64);
+ write(fd, &ok, sizeof(ok));
+ return NULL;
+ }
+--
+2.7.4
+
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 82565e35d7..1f26837f82 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mkinitfs
pkgver=3.0.4
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to generate initramfs images for Alpine"
url="http://git.alpinelinux.org/cgit/mkinitfs"
makedepends="kmod-dev util-linux-dev cryptsetup-dev linux-headers"
@@ -10,6 +10,7 @@ depends="acct busybox apk-tools>=2.0 lddtree>=1.25"
install="$pkgname.pre-upgrade $pkgname.post-install $pkgname.post-upgrade"
triggers="$pkgname.trigger=/usr/share/kernel/*"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz
+ 0001-nlplug-findfs-increase-the-sys-recursion-limit.patch
"
arch="all"
license="GPL2"
@@ -35,6 +36,9 @@ package() {
cd "$_builddir"
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="682a28918a7013d198b443e6b71a4df2 mkinitfs-3.0.4.tar.xz"
-sha256sums="f8ca92bf99870ba3076117e4af7fa56659bf2fa3f18a924507b6541ad10475cc mkinitfs-3.0.4.tar.xz"
-sha512sums="c0d2f6fb9d03afe2358dc0c1aecfd6aac46f69c63ed62e8513d525e54d3abb077f6b91ded4085c10480480d7ee3e8d0d6e91495b723ae2dc78c455d92329021d mkinitfs-3.0.4.tar.xz"
+md5sums="682a28918a7013d198b443e6b71a4df2 mkinitfs-3.0.4.tar.xz
+fc43c3f1f037b6902179c5d90c97c8fc 0001-nlplug-findfs-increase-the-sys-recursion-limit.patch"
+sha256sums="f8ca92bf99870ba3076117e4af7fa56659bf2fa3f18a924507b6541ad10475cc mkinitfs-3.0.4.tar.xz
+f7b983025fdb5cfdeedced11e445989e384e5d5773daf6f062ec32f8853b3cb7 0001-nlplug-findfs-increase-the-sys-recursion-limit.patch"
+sha512sums="c0d2f6fb9d03afe2358dc0c1aecfd6aac46f69c63ed62e8513d525e54d3abb077f6b91ded4085c10480480d7ee3e8d0d6e91495b723ae2dc78c455d92329021d mkinitfs-3.0.4.tar.xz
+fae8f44e2e2fa0898ee837fd88de5ada4ffb4c89c65fdda4ed3cffac7ae56c5dd6e01617f9b99a5e4aceacbd53ebdb879ea7c5562ecf0cbd7dce21af2f6da539 0001-nlplug-findfs-increase-the-sys-recursion-limit.patch"