aboutsummaryrefslogtreecommitdiffstats
path: root/main/mkinitfs
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-09-02 13:14:23 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-09-02 13:14:23 +0200
commitab7c60d53f55b02e79b5d2d3c3dcbff92ef12590 (patch)
tree0a369defc74f1c49e8fb56712df135bb625eba9c /main/mkinitfs
parent09cc4635f0827860df4b0ba603229b781b83c346 (diff)
downloadaports-ab7c60d53f55b02e79b5d2d3c3dcbff92ef12590.tar.bz2
aports-ab7c60d53f55b02e79b5d2d3c3dcbff92ef12590.tar.xz
main/mkinitfs: add K flag
Diffstat (limited to 'main/mkinitfs')
-rw-r--r--main/mkinitfs/0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch61
-rw-r--r--main/mkinitfs/APKBUILD12
2 files changed, 69 insertions, 4 deletions
diff --git a/main/mkinitfs/0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch b/main/mkinitfs/0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch
new file mode 100644
index 0000000000..23c59a1b9e
--- /dev/null
+++ b/main/mkinitfs/0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch
@@ -0,0 +1,61 @@
+From 3e2519f2930a318ef06ffb8bac01bae6fc1ee218 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Wed, 13 Jul 2016 14:49:28 +0000
+Subject: [PATCH 1/4] mkinitfs: add -K flag to copy host keys to new initramfs
+
+this is mainly to copy the developer keys present on build system
+to the target initramfs. simplifies creating your own initramfs
+and when your key is not packaged.
+---
+ mkinitfs.in | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/mkinitfs.in b/mkinitfs.in
+index 555bea8..d69ccc5 100755
+--- a/mkinitfs.in
++++ b/mkinitfs.in
+@@ -133,6 +133,7 @@ initfs_firmware() {
+
+ initfs_apk_keys() {
+ mkdir -p "$tmpdir"/etc/apk/keys
++ [ "$hostkeys" ] && cp "/etc/apk/keys/"* "$tmpdir"/etc/apk/keys/
+ cp "${basedir}etc/apk/keys/"* "$tmpdir"/etc/apk/keys/
+ }
+
+@@ -148,7 +149,7 @@ initfs_cpio() {
+
+ usage() {
+ cat <<EOF
+-usage: mkinitfs [-hkLl] [-b basedir] [-c configfile] [-F features] [-f fstab]
++usage: mkinitfs [-hkKLl] [-b basedir] [-c configfile] [-F features] [-f fstab]
+ [-i initfile ] [-o outfile] [-t tempdir] [kernelversion]"
+ options:
+ -b prefix files and kernel modules with basedir
+@@ -158,6 +159,7 @@ options:
+ -h print this help
+ -i use initfile as init instead of $init
+ -k keep tempdir
++ -K copy also host keys to initramfs
+ -l only list files that would have been used
+ -L list available features
+ -o set another outfile
+@@ -171,7 +173,7 @@ EOF
+ # main
+
+
+-while getopts "b:c:f:F:hi:kLlo:qt:" opt; do
++while getopts "b:c:f:F:hi:kKLlo:qt:" opt; do
+ case "$opt" in
+ b) basedir="$OPTARG";;
+ c) config="$OPTARG";;
+@@ -180,6 +182,7 @@ while getopts "b:c:f:F:hi:kLlo:qt:" opt; do
+ h) usage;;
+ i) init=$OPTARG;;
+ k) keeptmp=1;;
++ K) hostkeys=1;;
+ L) list_features=1;;
+ l) list_sources=1;;
+ o) outfile="$OPTARG";;
+--
+2.9.3
+
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index af524f130e..a7a3d9ecfa 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mkinitfs
pkgver=3.0.5
_ver=${pkgver%_git*}
-pkgrel=3
+pkgrel=4
pkgdesc="Tool to generate initramfs images for Alpine"
url="http://git.alpinelinux.org/cgit/mkinitfs"
makedepends_build=""
@@ -15,6 +15,7 @@ source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz
0001-init-add-support-for-ttyMFD-and-ttyUSB-serial-consol.patch
0001-init-dont-use-local-in-global-scope.patch
0001-group-sync-with-alpine-baselayout.patch
+ 0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch
"
arch="all"
license="GPL2"
@@ -33,12 +34,15 @@ package() {
md5sums="de3f95912a542dfabbf0573620549a29 mkinitfs-3.0.5.tar.xz
a4227598291fa7338ad1128bfef3720c 0001-init-add-support-for-ttyMFD-and-ttyUSB-serial-consol.patch
a74631b5f40001dd259a2a6ebcaec544 0001-init-dont-use-local-in-global-scope.patch
-db888a1a502fe281bbe0b1add81bf62f 0001-group-sync-with-alpine-baselayout.patch"
+db888a1a502fe281bbe0b1add81bf62f 0001-group-sync-with-alpine-baselayout.patch
+a46eb97de6742400ca04777a0a8478b2 0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch"
sha256sums="3f13619f161c506796b91f2db17644eba25c2ffc923aa0c8fff0213d1f660aa4 mkinitfs-3.0.5.tar.xz
17547dbc77bd19d940550ea6243b44212d21a6797aee4202e4e22c31143bf9e6 0001-init-add-support-for-ttyMFD-and-ttyUSB-serial-consol.patch
7253cd8ebc1487e4bfb98d81edd68b24a4364e9fa8e48c73fc6903f2077b056e 0001-init-dont-use-local-in-global-scope.patch
-17b8a04db505eea9e176da00f9389ca80f65ed88c0288f6785f9ab108164361a 0001-group-sync-with-alpine-baselayout.patch"
+17b8a04db505eea9e176da00f9389ca80f65ed88c0288f6785f9ab108164361a 0001-group-sync-with-alpine-baselayout.patch
+8daccc844576f0b06fc9c15a30d750bfecda019b476a0be4cf9bcd7139e219cf 0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch"
sha512sums="246f25ce3fb65ea19dbe611ad44a106930c28b2c7111908462d4a252433011280715b2cf87ee81cc6f0860679fd1d0a109d03040647498137e42b22ccc711662 mkinitfs-3.0.5.tar.xz
35b4cf3f74e394d87b321d335ec4dff6973bfd9a38cdc81609e21e025ee3fb9af7d2744cf9941531603df829af1f7fba433074915ba88a688d375cfe40dad07a 0001-init-add-support-for-ttyMFD-and-ttyUSB-serial-consol.patch
ca1bd66bc6d366dc74da389397f3e0d81b3afa21a534269230ab33f415e633b19ce54327b78713847461b67d6d23a85019c79e1fbbf1a964ee0bd26013ddf33f 0001-init-dont-use-local-in-global-scope.patch
-2736650e0c06d47f2cd0dcc4a9c3d575b2b5284ee8d1aa0cccd45b5855ff6704171f5b7761b8c88536c8dca84943810e9332db9f2e03681f6355c5068a3a3092 0001-group-sync-with-alpine-baselayout.patch"
+2736650e0c06d47f2cd0dcc4a9c3d575b2b5284ee8d1aa0cccd45b5855ff6704171f5b7761b8c88536c8dca84943810e9332db9f2e03681f6355c5068a3a3092 0001-group-sync-with-alpine-baselayout.patch
+712038089d3b58a3937549f25412803291690c992bd8e3002f02a46fc9c24903c94086704b5def3aecb422d46d7c501beeaa665000bc7da6ec20965e52eca5a1 0001-mkinitfs-add-K-flag-to-copy-host-keys-to-new-initram.patch"