aboutsummaryrefslogtreecommitdiffstats
path: root/main/mkinitfs
diff options
context:
space:
mode:
authorChristopher Brannon <chris@the-brannons.com>2018-05-23 07:28:22 -0700
committerJakub Jirutka <jakub@jirutka.cz>2018-05-24 21:57:12 +0200
commitf6a6625d91e36197d3ff2f5275dc097c848c95c2 (patch)
tree6876a7453b7c23a7c7b6f8a0c013e287520aa07a /main/mkinitfs
parent9647ca6a35bb397beba93ae79cb30a6fafbf0a3b (diff)
downloadaports-f6a6625d91e36197d3ff2f5275dc097c848c95c2.tar.bz2
aports-f6a6625d91e36197d3ff2f5275dc097c848c95c2.tar.xz
main/mkinitfs: fix the /boot/boot symlink to point at ., not /.
If /boot is on the root partition, I.E., no separate /boot partition, then the /boot/boot symlink incorrectly pointed to /. Pointing /boot/boot to "." is correct in all situations.
Diffstat (limited to 'main/mkinitfs')
-rw-r--r--main/mkinitfs/APKBUILD2
-rw-r--r--main/mkinitfs/mkinitfs.trigger2
2 files changed, 2 insertions, 2 deletions
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 5da95da54e..9d4f7ba871 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mkinitfs
pkgver=3.2.0
_ver=${pkgver%_git*}
-pkgrel=13
+pkgrel=14
pkgdesc="Tool to generate initramfs images for Alpine"
url="https://git.alpinelinux.org/cgit/mkinitfs"
arch="all"
diff --git a/main/mkinitfs/mkinitfs.trigger b/main/mkinitfs/mkinitfs.trigger
index cedf36337d..e8acc97854 100644
--- a/main/mkinitfs/mkinitfs.trigger
+++ b/main/mkinitfs/mkinitfs.trigger
@@ -18,7 +18,7 @@ done
# extlinux will use path relative partition, so if /boot is on a
# separate partition we want /boot/<kernel> resolve to /<kernel>
if ! [ -e /boot/boot ]; then
- ln -sf / /boot/boot
+ ln -sf . /boot/boot
fi
# cleanup unused initramfs