aboutsummaryrefslogtreecommitdiffstats
path: root/main/mpc1
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-07 20:19:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-10 08:34:04 +0000
commit75339e69c19646dedb30dd7f72806b477ead32cf (patch)
tree30751eea445ef56a404ea53a1b41eac283cbde45 /main/mpc1
parent494084ad2f34aaee8cf08eea0fe85b53d7250c30 (diff)
downloadaports-75339e69c19646dedb30dd7f72806b477ead32cf.tar.bz2
aports-75339e69c19646dedb30dd7f72806b477ead32cf.tar.xz
main/mpc1: new parallel version of libmpc
It needs to be parallel to current libmpc so we dont break gcc
Diffstat (limited to 'main/mpc1')
-rw-r--r--main/mpc1/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/mpc1/APKBUILD b/main/mpc1/APKBUILD
new file mode 100644
index 0000000000..572b496adc
--- /dev/null
+++ b/main/mpc1/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mpc1
+pkgver=1.0
+pkgrel=0
+pkgdesc="Multiprecision C library"
+url="http://www.multiprecision.org/"
+arch="all"
+license="LGPL-2.1"
+depends=
+makedepends="gmp-dev mpfr-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.multiprecision.org/mpc/download/mpc-$pkgver.tar.gz"
+
+_builddir="$srcdir"/mpc-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ # workaround for a bug in configure script
+ EGREP=egrep \
+ ./configure --prefix=/usr \
+ --build=${CBUILD} \
+ --host=${CHOST} \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+md5sums="13370ceb2e266c5eeb2f7e78c24b7858 mpc-1.0.tar.gz"