aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-03-17 07:00:46 -0400
committerTimo Teräs <timo.teras@iki.fi>2017-03-20 08:30:11 +0000
commit014f75382beb4df3a42ab568d2c98edc1dc9f143 (patch)
tree4fe8cdc77fa3db124aa6b7eb18ba574807483caf /main/musl
parent9a64b160eb7e323df51687a6a6f367b67d1ef89f (diff)
downloadaports-014f75382beb4df3a42ab568d2c98edc1dc9f143.tar.bz2
aports-014f75382beb4df3a42ab568d2c98edc1dc9f143.tar.xz
main/musl: s390x fpreg_t patch
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/0009-fix-fpreg_t-remove-unused-per_struct-s390x.patch40
-rw-r--r--main/musl/APKBUILD2
2 files changed, 42 insertions, 0 deletions
diff --git a/main/musl/0009-fix-fpreg_t-remove-unused-per_struct-s390x.patch b/main/musl/0009-fix-fpreg_t-remove-unused-per_struct-s390x.patch
new file mode 100644
index 0000000000..3dbbb84234
--- /dev/null
+++ b/main/musl/0009-fix-fpreg_t-remove-unused-per_struct-s390x.patch
@@ -0,0 +1,40 @@
+From 74bca42e1613c58805d7b048841c2fa8f8502158 Mon Sep 17 00:00:00 2001
+From: "Tuan M. Hoang" <tmhoang@flatglobe.org>
+Date: Tue, 14 Mar 2017 16:44:04 -0400
+Subject: s390x: fix fpreg_t and remove unused per_struct
+
+Including sys/procfs.h complains unknown type name 'fpreg_t' in
+bits/user.h. fpreg_t in bits/signal.h and elf_fpreg_t in bits/user.h
+are practically the same.
+
+per_struct is never used, even conflicts with kernel header
+asm/ptrace.h
+---
+ arch/s390x/bits/user.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/s390x/bits/user.h b/arch/s390x/bits/user.h
+index 90f07b7..17bce16 100644
+--- a/arch/s390x/bits/user.h
++++ b/arch/s390x/bits/user.h
+@@ -8,7 +8,7 @@ typedef union {
+
+ typedef struct {
+ unsigned fpc;
+- fpreg_t fprs[16];
++ elf_fpreg_t fprs[16];
+ } elf_fpregset_t;
+
+ #define ELF_NGREG 27
+@@ -32,7 +32,7 @@ struct _user_per_struct {
+ unsigned short perc_atmid;
+ unsigned long address;
+ unsigned char access_id;
+-} per_struct;
++};
+
+ struct _user_regs_struct {
+ struct _user_psw_struct psw;
+--
+cgit v0.11.2
+
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 6b748441f6..9a83d4ceea 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -25,6 +25,7 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0006-fix-crash-from-corrupted-tls-module-list-after-faile.patch
0007-add-s390x-dlsym.patch
0008-fix-ld-behavior-dependent-crash-in-ppc64-ldso-startu.patch
+ 0009-fix-fpreg_t-remove-unused-per_struct-s390x.patch
ldconfig
__stack_chk_fail_local.c
@@ -153,6 +154,7 @@ df96c4bd5ff9c197c8aa599948b69716587837de0f298d3adec56077b073e71a49a3c3345e0508cf
4dc5cdcab11dee6b62fcb81401a816341e1d802a99e46b072c51575a2c25933354540fe22ae06dcdc85eb9a3cbf7256e7c43aab0e75843846551f9e18bfc39c2 0006-fix-crash-from-corrupted-tls-module-list-after-faile.patch
39eaf56fe30c7098c75c09567a0d990b90c1017c1c2c160017b2d5f41e6503a23d21c7b20bad0186cf3e6fec9fa28ab4f7d655a8382140186c96302f262379fe 0007-add-s390x-dlsym.patch
4018ca56adef65df0041805b9359caba467c7f95fe40cba90dfd32333b7dab180bff519b42f8c56c55eab88a35c040bdf4882e15ce5f6dcf155d545578ab8f7b 0008-fix-ld-behavior-dependent-crash-in-ppc64-ldso-startu.patch
+8060f8094c55857a7f21be6d5092e249eebf312507e02c1e6a469824407f5399e613fa3e47af25ed0c91bf0d5cedb325a92908b137727ca588996daf75037606 0009-fix-fpreg_t-remove-unused-per_struct-s390x.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c
0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d getconf.c