aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-10-20 08:14:43 +0300
committerTimo Teräs <timo.teras@iki.fi>2015-10-20 08:14:43 +0300
commit42785f65cf2e4f1c28a2d45243d32de396c169d3 (patch)
treef18e06e86e1284149d46b395f40f41c8f3e943dc /main/musl
parent332ad9b94d0cfaabf308d39c8f0a2c6f3d4b2b61 (diff)
downloadaports-42785f65cf2e4f1c28a2d45243d32de396c169d3.tar.bz2
aports-42785f65cf2e4f1c28a2d45243d32de396c169d3.tar.xz
main/musl: upgrade to 1.1.12
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch33
-rw-r--r--main/musl/0002-implement-arm-eabi-mem-functions.patch83
-rw-r--r--main/musl/0003-fix-fclose-of-permanent-stdin-out-err-streams.patch50
-rw-r--r--main/musl/0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch46
-rw-r--r--main/musl/0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch25
-rw-r--r--main/musl/0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch40
-rw-r--r--main/musl/0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch31
-rw-r--r--main/musl/0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch36
-rw-r--r--main/musl/APKBUILD42
9 files changed, 5 insertions, 381 deletions
diff --git a/main/musl/0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch b/main/musl/0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch
deleted file mode 100644
index 1b19b8582d..0000000000
--- a/main/musl/0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d18cf76d73df8f9cc751d4b4ba5a635c70c0c645 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Sun, 30 Aug 2015 18:44:58 +0000
-Subject: [PATCH] remove use of buggy .SECONDARY special target in makefile
-
-this functionality is affected by GNU make bug #30653, "intermediate
-files incorrectly pruned in parallel builds". on affected versions of
-make, parallel builds attempt to compile source files before
-alltypes.h is generated.
-
-as noted with commit a91ebdcfac6804714a1fe39f4375e2b4ebab085b, which
-added the use of .SECONDARY, suppression of removal of "intermediate"
-files does not seem to be needed at present. if it is needed in the
-future, it should be achievable by explicitly mentioning their names
-as targets or prerequisites.
----
- Makefile | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 07336d2..5a6a43b 100644
---- a/Makefile
-+++ b/Makefile
-@@ -203,6 +203,4 @@ musl-git-%.tar.gz: .git
- musl-%.tar.gz: .git
- git archive --format=tar.gz --prefix=$(patsubst %.tar.gz,%,$@)/ -o $@ v$(patsubst musl-%.tar.gz,%,$@)
-
--.SECONDARY:
--
- .PHONY: all clean install install-libs install-headers install-tools
---
-2.5.1
-
diff --git a/main/musl/0002-implement-arm-eabi-mem-functions.patch b/main/musl/0002-implement-arm-eabi-mem-functions.patch
deleted file mode 100644
index a52c2b6211..0000000000
--- a/main/musl/0002-implement-arm-eabi-mem-functions.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From d8be1bc0193f45d3900f8466f26d1411b7f919c3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Sun, 30 Aug 2015 18:58:26 +0300
-Subject: [PATCH] implement arm eabi mem* functions
-
-these functions are part of the ARM EABI, meaning compilers may
-generate references to them. known versions of gcc do not use them,
-but llvm does. they are not provided by libgcc, and the de facto
-standard seems to be that libc provides them.
----
- arch/arm/src/__aeabi_memclr.c | 9 +++++++++
- arch/arm/src/__aeabi_memcpy.c | 9 +++++++++
- arch/arm/src/__aeabi_memmove.c | 9 +++++++++
- arch/arm/src/__aeabi_memset.c | 9 +++++++++
- 4 files changed, 36 insertions(+)
- create mode 100644 arch/arm/src/__aeabi_memclr.c
- create mode 100644 arch/arm/src/__aeabi_memcpy.c
- create mode 100644 arch/arm/src/__aeabi_memmove.c
- create mode 100644 arch/arm/src/__aeabi_memset.c
-
-diff --git a/arch/arm/src/__aeabi_memclr.c b/arch/arm/src/__aeabi_memclr.c
-new file mode 100644
-index 0000000..a25306d
---- /dev/null
-+++ b/arch/arm/src/__aeabi_memclr.c
-@@ -0,0 +1,9 @@
-+#include <string.h>
-+#include "libc.h"
-+
-+void __aeabi_memclr(void *dest, size_t n)
-+{
-+ memset(dest, 0, n);
-+}
-+weak_alias(__aeabi_memclr, __aeabi_memclr4);
-+weak_alias(__aeabi_memclr, __aeabi_memclr8);
-diff --git a/arch/arm/src/__aeabi_memcpy.c b/arch/arm/src/__aeabi_memcpy.c
-new file mode 100644
-index 0000000..4ae5c77
---- /dev/null
-+++ b/arch/arm/src/__aeabi_memcpy.c
-@@ -0,0 +1,9 @@
-+#include <string.h>
-+#include "libc.h"
-+
-+void __aeabi_memcpy(void *restrict dest, const void *restrict src, size_t n)
-+{
-+ memcpy(dest, src, n);
-+}
-+weak_alias(__aeabi_memcpy, __aeabi_memcpy4);
-+weak_alias(__aeabi_memcpy, __aeabi_memcpy8);
-diff --git a/arch/arm/src/__aeabi_memmove.c b/arch/arm/src/__aeabi_memmove.c
-new file mode 100644
-index 0000000..951e7d3
---- /dev/null
-+++ b/arch/arm/src/__aeabi_memmove.c
-@@ -0,0 +1,9 @@
-+#include <string.h>
-+#include "libc.h"
-+
-+void __aeabi_memmove(void *dest, const void *src, size_t n)
-+{
-+ memmove(dest, src, n);
-+}
-+weak_alias(__aeabi_memmove, __aeabi_memmove4);
-+weak_alias(__aeabi_memmove, __aeabi_memmove8);
-diff --git a/arch/arm/src/__aeabi_memset.c b/arch/arm/src/__aeabi_memset.c
-new file mode 100644
-index 0000000..8929975
---- /dev/null
-+++ b/arch/arm/src/__aeabi_memset.c
-@@ -0,0 +1,9 @@
-+#include <string.h>
-+#include "libc.h"
-+
-+void __aeabi_memset(void *dest, size_t n, int c)
-+{
-+ memset(dest, c, n);
-+}
-+weak_alias(__aeabi_memset, __aeabi_memset4);
-+weak_alias(__aeabi_memset, __aeabi_memset8);
---
-2.5.1
-
diff --git a/main/musl/0003-fix-fclose-of-permanent-stdin-out-err-streams.patch b/main/musl/0003-fix-fclose-of-permanent-stdin-out-err-streams.patch
deleted file mode 100644
index 53d8b65719..0000000000
--- a/main/musl/0003-fix-fclose-of-permanent-stdin-out-err-streams.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 426a0e2912c07f0e86feee2ed12f24a808eac2f4 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Wed, 9 Sep 2015 04:31:07 +0000
-Subject: [PATCH] fix fclose of permanent (stdin/out/err) streams
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-this fixes a bug reported by Nuno Gonçalves. previously, calling
-fclose on stdin or stdout resulted in deadlock at exit time, since
-__stdio_exit attempts to lock these streams to flush/seek them, and
-has no easy way of knowing that they were closed.
-
-conceptually, leaving a FILE stream locked on fclose is valid since,
-in the abstract machine, it ceases to exist. but to satisfy the
-implementation-internal assumption in __stdio_exit that it can access
-these streams unconditionally, we need to unlock them.
-
-it's also necessary that fclose leaves permanent streams in a state
-where __stdio_exit will not attempt any further operations on them.
-fortunately, the call to fflush already yields this property.
----
- src/stdio/fclose.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/stdio/fclose.c b/src/stdio/fclose.c
-index 839d88a..d687a87 100644
---- a/src/stdio/fclose.c
-+++ b/src/stdio/fclose.c
-@@ -9,7 +9,7 @@ int fclose(FILE *f)
- int r;
- int perm;
-
-- FFINALLOCK(f);
-+ FLOCK(f);
-
- __unlist_locked_file(f);
-
-@@ -26,6 +26,7 @@ int fclose(FILE *f)
-
- if (f->getln_buf) free(f->getln_buf);
- if (!perm) free(f);
--
-+ else FUNLOCK(f);
-+
- return r;
- }
---
-2.5.1
-
diff --git a/main/musl/0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch b/main/musl/0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch
deleted file mode 100644
index 2148656679..0000000000
--- a/main/musl/0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 844212d94f582c4e3c5055e0a1524931e89ebe76 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Wed, 9 Sep 2015 05:13:33 +0000
-Subject: [PATCH] make nl_langinfo(CODESET) always return "UTF-8"
-
-this restores the original behavior prior to the addition of the
-byte-based C locale and fixes what is effectively a regression in
-musl's property of always providing working UTF-8 support.
-
-commit 1507ebf837334e9e07cfab1ca1c2e88449069a80 introduced the codeset
-name "UTF-8-CODE-UNITS" for the byte-based C locale to represent that
-the semantic content is UTF-8 but that it is being processed as code
-units (bytes) rather than whole multibyte characters. however, many
-programs assume that the codeset name is usable with iconv and/or
-comes from a set of standard/widely-used names known to the
-application. such programs are likely to produce warnings or errors,
-run with reduced functionality, or mangle character data when run
-explicitly in the C locale.
-
-the standard places basically no requirements for the string returned
-by nl_langinfo(CODESET) and how it interacts with other interfaces, so
-returning "UTF-8" is permissible. moreover, it seems like the right
-thing to do, since the identity of the character encoding as "UTF-8"
-is independent of whether it is being processed as bytes of characters
-by the standard library functions.
----
- src/locale/langinfo.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/locale/langinfo.c b/src/locale/langinfo.c
-index 776b447..69693ff 100644
---- a/src/locale/langinfo.c
-+++ b/src/locale/langinfo.c
-@@ -33,8 +33,7 @@ char *__nl_langinfo_l(nl_item item, locale_t loc)
- int idx = item & 65535;
- const char *str;
-
-- if (item == CODESET)
-- return MB_CUR_MAX==1 ? "UTF-8-CODE-UNITS" : "UTF-8";
-+ if (item == CODESET) "UTF-8";
-
- switch (cat) {
- case LC_NUMERIC:
---
-2.5.1
-
diff --git a/main/musl/0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch b/main/musl/0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch
deleted file mode 100644
index bd815159b6..0000000000
--- a/main/musl/0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 58f6259dff804faa416df4f9b1ca2fc61d178585 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Wed, 9 Sep 2015 06:04:42 +0000
-Subject: [PATCH] fix breakage in nl_langinfo from previous commit
-
----
- src/locale/langinfo.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/locale/langinfo.c b/src/locale/langinfo.c
-index 69693ff..a1ada24 100644
---- a/src/locale/langinfo.c
-+++ b/src/locale/langinfo.c
-@@ -33,7 +33,7 @@ char *__nl_langinfo_l(nl_item item, locale_t loc)
- int idx = item & 65535;
- const char *str;
-
-- if (item == CODESET) "UTF-8";
-+ if (item == CODESET) return "UTF-8";
-
- switch (cat) {
- case LC_NUMERIC:
---
-2.5.1
-
diff --git a/main/musl/0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch b/main/musl/0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch
deleted file mode 100644
index 88b6f9f6e8..0000000000
--- a/main/musl/0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From deb85ab44dbe784ba6174b8cf376d35aeacbe309 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Wed, 9 Sep 2015 06:59:45 +0000
-Subject: [PATCH] remove unused (and invalid) C version of sigsetjmp
-
-originally, the comment in this code was correct and it would likely
-work if the compiler generated a tail call to setjmp. however, commit
-583e55122e767b1586286a0d9c35e2a4027998ab redesigned sigsetjmp and
-siglongjmp such that the old C implementation (which was not intended
-to be used) is not even conceptually correct. remove it in the
-interest of avoiding confusion when porting to new archs.
----
- src/signal/sigsetjmp.c | 17 -----------------
- 1 file changed, 17 deletions(-)
-
-diff --git a/src/signal/sigsetjmp.c b/src/signal/sigsetjmp.c
-index 1bbe1a0..e69de29 100644
---- a/src/signal/sigsetjmp.c
-+++ b/src/signal/sigsetjmp.c
-@@ -1,17 +0,0 @@
--#include <setjmp.h>
--#include <signal.h>
--#include "libc.h"
--
--/* !!! This function will not work unless the compiler performs
-- * tail call optimization. Machine-specific asm versions should
-- * be created instead even though the workaround (tail call)
-- * is entirely non-machine-specific... */
--
--int sigsetjmp(sigjmp_buf buf, int save)
--{
-- if ((buf->__fl = save))
-- pthread_sigmask(SIG_SETMASK, 0, (sigset_t *)buf->__ss);
-- return setjmp(buf);
--}
--
--weak_alias(sigsetjmp, __sigsetjmp);
---
-2.5.1
-
diff --git a/main/musl/0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch b/main/musl/0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch
deleted file mode 100644
index b72fc04a38..0000000000
--- a/main/musl/0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 878887c50cccd45b5cabe6ed2ac743941f3417ea Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Wed, 9 Sep 2015 07:18:28 +0000
-Subject: [PATCH] fix missing earlyclobber flag in i386 a_ctz_64 asm
-
-this error was only found by reading the code, but it seems to have
-been causing gcc to produce wrong code in malloc: the same register
-was used for the output and the high word of the input. in principle
-this could have caused an infinite loop searching for an available
-bin, but in practice most x86 models seem to implement the "undefined"
-result of the bsf instruction as "unchanged".
----
- arch/i386/atomic.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/arch/i386/atomic.h b/arch/i386/atomic.h
-index 25441df..fd222ea 100644
---- a/arch/i386/atomic.h
-+++ b/arch/i386/atomic.h
-@@ -7,7 +7,7 @@ static inline int a_ctz_64(uint64_t x)
- {
- int r;
- __asm__( "bsf %1,%0 ; jnz 1f ; bsf %2,%0 ; addl $32,%0\n1:"
-- : "=r"(r) : "r"((unsigned)x), "r"((unsigned)(x>>32)) );
-+ : "=&r"(r) : "r"((unsigned)x), "r"((unsigned)(x>>32)) );
- return r;
- }
-
---
-2.5.1
-
diff --git a/main/musl/0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch b/main/musl/0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch
deleted file mode 100644
index 5422e5a3aa..0000000000
--- a/main/musl/0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From cb1c88d42b0ee5e950d85e933c6eb6ecb8175e1d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Fri, 11 Sep 2015 06:15:06 +0000
-Subject: [PATCH] fix uninitialized scopeid in lookups from hosts file and ip
- literals
-
----
- src/network/lookup_ipliteral.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/network/lookup_ipliteral.c b/src/network/lookup_ipliteral.c
-index 7bcb85f..7ca70b2 100644
---- a/src/network/lookup_ipliteral.c
-+++ b/src/network/lookup_ipliteral.c
-@@ -24,7 +24,7 @@ int __lookup_ipliteral(struct address buf[static 1], const char *name, int famil
- if (family != AF_INET) {
- char tmp[64];
- char *p = strchr(name, '%'), *z;
-- unsigned long long scopeid;
-+ unsigned long long scopeid = 0;
- if (p && p-name < 64) {
- memcpy(tmp, name, p-name);
- tmp[p-name] = 0;
-@@ -44,8 +44,8 @@ int __lookup_ipliteral(struct address buf[static 1], const char *name, int famil
- if (!scopeid) return EAI_NONAME;
- }
- if (scopeid > UINT_MAX) return EAI_NONAME;
-- buf[0].scopeid = scopeid;
- }
-+ buf[0].scopeid = scopeid;
- return 1;
- }
- return 0;
---
-2.5.1
-
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index d508467df6..a6075980df 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
-pkgver=1.1.11
-pkgrel=2
+pkgver=1.1.12
+pkgrel=0
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -12,14 +12,6 @@ depends_dev="!uclibc-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-utils $pkgname-dbg libc6-compat:compat"
source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
- 0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch
- 0002-implement-arm-eabi-mem-functions.patch
- 0003-fix-fclose-of-permanent-stdin-out-err-streams.patch
- 0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch
- 0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch
- 0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch
- 0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch
- 0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch
ldconfig
__stack_chk_fail_local.c
@@ -135,43 +127,19 @@ compat() {
done
}
-md5sums="48be0777e32f374d387e9cf85e36ec4d musl-1.1.11.tar.gz
-df95d85134e21b7cd0711aa3edec4a14 0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch
-31462dce2f13f68868cf2dc61e05c6da 0002-implement-arm-eabi-mem-functions.patch
-45e86522164079c6067994f78c8491e9 0003-fix-fclose-of-permanent-stdin-out-err-streams.patch
-edd5e3088b1ad3c1a38d3078a5feadc8 0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch
-0b50a3d050c997ad732eedb328559183 0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch
-b6f8dbcfe6fb6e25ae30a16bf6485795 0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch
-554812ae180748662f3f5eb0c136e928 0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch
-a68989df58c9af8ded55aeaace6f3993 0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch
+md5sums="42875e0c111aa1cb9d08663f8d42c799 musl-1.1.12.tar.gz
830d01f7821b978df770b06db3790921 ldconfig
0df687757221bbb0fc1aa67f1bd646f9 __stack_chk_fail_local.c
57ef2c63b9ec6a2041694ace97d4ffa2 getconf.c
2b941c4251cac44988a4abfc50e21267 getent.c
45f92f8d59cf84d765de698a9578dbf4 iconv.c"
-sha256sums="bb9e6da51b7b12641f5d1abb39705c6c6c1b2fbd20002362948aa736a0aa353f musl-1.1.11.tar.gz
-68bea76fece3285f6e648cb86fb2bf80d099543332494d5c74fc1b419218dc93 0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch
-2cc704dac5f566bff09228a571012d75fad99852357b2c303526155bb599a137 0002-implement-arm-eabi-mem-functions.patch
-4d0fb3496d33ed1d376a9a1aec565d7d71c5d2764048668258fc5e3f995b9d2c 0003-fix-fclose-of-permanent-stdin-out-err-streams.patch
-f743049757fdfb0d67620ae2783370372a0720509d18c9551b47220f21066bbd 0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch
-d15e48f74f760651394dd460ebbb3356c42e56027b2708992b4db7c92e1c40a2 0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch
-2310fba590d57cd7193048d49c0bbab0fffe81fd2266d26bc750f9ed96787c27 0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch
-47f4d1049658bbe3b59f17b0b7f16c901f2de14c89eb9640b5c98d4ff4fd9813 0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch
-f1e47791bb59bbfcb07a6f4b8c4bb9d1680acdaa00ad202b9e03a218b25fe288 0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch
+sha256sums="720b83c7e276b4b679c0bffe9509340d5f81fd601508e607e708177df0d31c0e musl-1.1.12.tar.gz
b4a2c06db38742e8c42c3c9838b285a7d8cdac6c091ff3df5ff9a15f1e41b9c7 ldconfig
299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da __stack_chk_fail_local.c
d87d0cbb3690ae2c5d8cc218349fd8278b93855dd625deaf7ae50e320aad247c getconf.c
68373a55e89ce85c562d941ccf588337d6cc6c9c17689d695f65cd7607134bbe getent.c
f79a2930a2e5bb0624321589edf8b889d1e9b603e01e6b7ae214616605b3fdd7 iconv.c"
-sha512sums="573131fe7a2c5a9c9bf796a5fc02e6ec093148648b9b43dc13d9c85e5777b1691499af6f673075a0d2b4b36c788b4dd7d72eb450c6ec3a586901bd410ee1ea6d musl-1.1.11.tar.gz
-4b3bfb0b3a6e5c72dad3813a9606d646077ef4e5d3cf68c8d8a03a4e026f2f4d5f96155ccf5ba8ff170ff529d3d78432bcdc9f164941b140beac240feff6c835 0001-remove-use-of-buggy-.SECONDARY-special-target-in-mak.patch
-663817a4b9ef9cde4cf45485ac974c1775da1854769d168fde98d8982498e7eed05b72e840613996c577e9097a4697fe39079f06038dd7bb4ba1f812cecdc8df 0002-implement-arm-eabi-mem-functions.patch
-a7d63a7d70aa71104ccef9c530cdd5b76d1cf5f6f372ec56ac5d636b1ccbcf2c3f639712ba96e98068f1fb6511b7d8dbd251df23e3b8e3c09ee7538eaa2dbc0b 0003-fix-fclose-of-permanent-stdin-out-err-streams.patch
-64e74b1c042a032657ffba29f4a933fbb47d2108281957812e05a6cdd2d3431e79d1ed4ad7c0a4acbd281593cc63a31a5c482163f890e0fbba8f20c1c507928f 0004-make-nl_langinfo-CODESET-always-return-UTF-8.patch
-d1ad5d8ee7f9dbb337d7df6a2d851b47db51ae42df6c3219e1657c9a73b6b36ba72fe4f55d8685c19024f21b9ae3da2336e1800e3b3c67238f5d74bae1280827 0005-fix-breakage-in-nl_langinfo-from-previous-commit.patch
-ef12fed5f595ebfafe948225eab7fde24ff11384ddd3f5542a092df264a6d6459fc3d0998e5ed98b290139371164fa022250faf6122049ef1f62e37692435bfd 0006-remove-unused-and-invalid-C-version-of-sigsetjmp.patch
-5dff942055f916ea45a19063d647187ce79aca8a2cbc64e5fa19ae15b13dab866db5a2916077172eadc77df353f2dbc5e5850164456d3a46738d7e7f85486af2 0007-fix-missing-earlyclobber-flag-in-i386-a_ctz_64-asm.patch
-828ded1a37a6818b28a944b4eda5d2a5e06615b3c21eaeebf600b66e304efd4c2883e755adcee735cc9a19d24acc49de6a8f997e9804a54c463491cbe41c5d53 0008-fix-uninitialized-scopeid-in-lookups-from-hosts-file.patch
+sha512sums="7cabbe2665e32bd3408c8865f89f474106e982b4e5de81d0cdeea19e19e20b4d2496faf1adc6b2811d996f30f39258184ba347e8eb5f3811eab89179e8f52d70 musl-1.1.12.tar.gz
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c
0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d getconf.c