aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-05 12:07:33 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 10:29:54 +0000
commit658ce467c6b897f1ad5e3b90df18444e34cc9bdf (patch)
tree144161e1434027ffd08c23468dc2df5f414050a4 /main/musl
parente04197e04add1d03bf5f0ade685fa9e59a487293 (diff)
downloadaports-658ce467c6b897f1ad5e3b90df18444e34cc9bdf.tar.bz2
aports-658ce467c6b897f1ad5e3b90df18444e34cc9bdf.tar.xz
main/musl: fix bootstrap build
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 17bc23f24b..5d7effbc25 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -44,11 +44,13 @@ build() {
${CROSS_COMPILE}gcc $CPPFLAGS $CFLAGS -c "$srcdir"/__stack_chk_fail_local.c -o __stack_chk_fail_local.o || return 1
${CROSS_COMPILE}ar r libssp_nonshared.a __stack_chk_fail_local.o || return 1
- # getconf/getent/iconv
- local i
- for i in getconf getent iconv ; do
- ${CROSS_COMPILE}gcc $CPPFLAGS $CFLAGS "$srcdir"/$i.c -o $i || return 1
- done
+ if [ "$BOOTSTRAP" != "noutils" ]; then
+ # getconf/getent/iconv
+ local i
+ for i in getconf getent iconv ; do
+ ${CROSS_COMPILE}gcc $CPPFLAGS $CFLAGS "$srcdir"/$i.c -o $i || return 1
+ done
+ fi
# note: not autotools
LDFLAGS="$LDFLAGS -Wl,-soname,libc.musl-${CARCH}.so.1" \
@@ -92,11 +94,14 @@ utils() {
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/sbin
mv "$pkgdir"/usr/bin/ldd "$subpkgdir"/usr/bin
find "$pkgdir" -type d -delete 2>/dev/null
- install -D \
- "$_builddir"/getent \
- "$_builddir"/getconf \
- "$_builddir"/iconv \
- "$subpkgdir"/usr/bin
+
+ if [ "$BOOTSTRAP" != "noutils" ]; then
+ install -D \
+ "$_builddir"/getent \
+ "$_builddir"/getconf \
+ "$_builddir"/iconv \
+ "$subpkgdir"/usr/bin
+ fi
install -D -m755 "$srcdir"/ldconfig "$subpkgdir"/sbin
}