aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-24 11:58:32 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-27 06:23:05 +0000
commitf9110e603a3ce00536142e4caeae8f3db1fc48a1 (patch)
treebab8401b2e1dbbcfd74e8633d8ca26f3318a57e5 /main/musl
parentf5c4b298918ba1d5ff85861cdeed9eff2cbcd5b9 (diff)
downloadaports-f9110e603a3ce00536142e4caeae8f3db1fc48a1.tar.bz2
aports-f9110e603a3ce00536142e4caeae8f3db1fc48a1.tar.xz
scripts/bootstrap.sh, main/{binutils,gcc,musl}: no more options="toolchain"
abuild has been updated to figure this one out from $BOOTSTRAP.
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 255c4fb75c..2d6002b2f8 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -9,7 +9,6 @@ arch="all"
license="MIT"
depends=""
depends_dev="!uclibc-dev"
-options="toolchain"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-dbg libc6-compat:compat:noarch"
case "$BOOTSTRAP" in
@@ -42,7 +41,7 @@ builddir="$srcdir"/musl-$pkgver
build() {
cd "$builddir"
- [ "$BOOTSTRAP" == "nocc" ] && return 0
+ [ "$BOOTSTRAP" = "nocc" ] && return 0
# provide minimal libssp_nonshared.a so we don't need libssp from gcc
${CROSS_COMPILE}gcc $CPPFLAGS $CFLAGS -c "$srcdir"/__stack_chk_fail_local.c -o __stack_chk_fail_local.o || return 1
@@ -73,7 +72,7 @@ build() {
package() {
cd "$builddir"
- if [ "$BOOTSTRAP" == "nocc" ]; then
+ if [ "$BOOTSTRAP" = "nocc" ]; then
case "$CARCH" in
aarch64*) ARCH="aarch64" ;;
arm*) ARCH="arm" ;;