aboutsummaryrefslogtreecommitdiffstats
path: root/main/nghttp2
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-06-20 02:42:16 +0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-06-22 07:26:24 +0000
commit1475c049d444ba1d9525de900a56f0fc4615ff7c (patch)
treef5546462b307ece25fcf09435b3528b8a5b71eb9 /main/nghttp2
parenta68667230e709d4d1176e13ecd1e2f742115e55d (diff)
downloadaports-1475c049d444ba1d9525de900a56f0fc4615ff7c.tar.bz2
aports-1475c049d444ba1d9525de900a56f0fc4615ff7c.tar.xz
main/nghttp2: upgrade to 1.32.0
Diffstat (limited to 'main/nghttp2')
-rw-r--r--main/nghttp2/APKBUILD10
-rw-r--r--main/nghttp2/libressl-2.7.patch43
2 files changed, 4 insertions, 49 deletions
diff --git a/main/nghttp2/APKBUILD b/main/nghttp2/APKBUILD
index 5af04b4575..0a0ccf0125 100644
--- a/main/nghttp2/APKBUILD
+++ b/main/nghttp2/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
-pkgver=1.31.1
+pkgver=1.32.0
pkgrel=0
pkgdesc="Experimental HTTP/2 client, server and proxy"
-url="https://nghttp2.org/"
+url="https://nghttp2.org"
arch="all"
license="MIT"
makedepends="libev-dev libressl-dev zlib-dev c-ares-dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz
- libressl-2.7.patch"
+source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
check() {
@@ -44,5 +43,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e0f5b345b6d794b21fa04bc0c7125f24a877074538ad746451d4a293eb22f1afb9e0e619c69b84f0fc2142a925044a19976af4cffb8426358e95e7d9715d5a4f nghttp2-1.31.1.tar.xz
-b6d2fea4d76253cc7e8a4387f77fbde8f2b7aec09ec7c48ccd7c499571786244c29ec917714b37eb458404351b179bb0af0c62c150450114b59f47d5c44f8dd7 libressl-2.7.patch"
+sha512sums="ec7e417fbc5497861d2b6dde5145da1640b36441882824e85940e5ca6ac52ec444aa7123846960f7211dd96462eab421d39f9cc49454f3f52e0dcdb36402044e nghttp2-1.32.0.tar.xz"
diff --git a/main/nghttp2/libressl-2.7.patch b/main/nghttp2/libressl-2.7.patch
deleted file mode 100644
index 8b3b793452..0000000000
--- a/main/nghttp2/libressl-2.7.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-reported upstream:
-https://github.com/nghttp2/nghttp2/issues/1156
-
-diff --git a/configure.ac b/configure.ac
-index 9445f93..1a8eae5 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -359,6 +359,11 @@ PKG_CHECK_MODULES([OPENSSL], [openssl >= 1.0.1],
- if test "x${have_openssl}" = "xno"; then
- AC_MSG_NOTICE($OPENSSL_PKG_ERRORS)
- fi
-+save_LIBS=$LIBS
-+LIBS=$OPENSSL_LIBS
-+AC_CHECK_FUNCS(BIO_set_data BIO_get_data BIO_set_init)
-+LIBS=$save_LIBS
-+
-
- # c-ares (for src)
- PKG_CHECK_MODULES([LIBCARES], [libcares >= 1.7.5], [have_libcares=yes],
-diff --git a/src/shrpx_connection.cc b/src/shrpx_connection.cc
-index 06ad958..e5cf1be 100644
---- a/src/shrpx_connection.cc
-+++ b/src/shrpx_connection.cc
-@@ -44,13 +44,15 @@ using namespace nghttp2;
-
- namespace shrpx {
-
--#if !OPENSSL_1_1_API
--
-+#ifndef HAVE_BIO_GET_DATA
- void *BIO_get_data(BIO *bio) { return bio->ptr; }
-+#endif
-+#ifndef HAVE_BIO_SET_DATA
- void BIO_set_data(BIO *bio, void *ptr) { bio->ptr = ptr; }
-+#endif
-+#ifndef HAVE_BIO_SET_INIT
- void BIO_set_init(BIO *bio, int init) { bio->init = init; }
--
--#endif // !OPENSSL_1_1_API
-+#endif
-
- Connection::Connection(struct ev_loop *loop, int fd, SSL *ssl,
- MemchunkPool *mcpool, ev_tstamp write_timeout,