aboutsummaryrefslogtreecommitdiffstats
path: root/main/nghttp2
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-28 06:12:10 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-28 06:12:15 +0000
commitb48d1351556fdae3cb3f1354630121fe7d5a70eb (patch)
tree753486f237c5bf5ecab1cadc4d45eb76f1dae57a /main/nghttp2
parentd43674146ecb03e518be8c2624b067d0ef758133 (diff)
downloadaports-b48d1351556fdae3cb3f1354630121fe7d5a70eb.tar.bz2
aports-b48d1351556fdae3cb3f1354630121fe7d5a70eb.tar.xz
main/nghttp2: upgrade to 1.21.0, modernize APKBUILD
Diffstat (limited to 'main/nghttp2')
-rw-r--r--main/nghttp2/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/main/nghttp2/APKBUILD b/main/nghttp2/APKBUILD
index b662e3b859..5e6f82d5e4 100644
--- a/main/nghttp2/APKBUILD
+++ b/main/nghttp2/APKBUILD
@@ -1,19 +1,22 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
-pkgver=1.20.0
+pkgver=1.21.0
pkgrel=0
pkgdesc="Experimental HTTP/2 client, server and proxy"
url="https://nghttp2.org/"
arch="all"
license="MIT"
-depends=""
makedepends="libev-dev libressl-dev zlib-dev c-ares-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
+check() {
+ cd "$builddir"
+ make check
+}
+
build() {
cd "$builddir"
./configure \
@@ -30,14 +33,13 @@ build() {
--without-neverbleed \
--without-jemalloc \
--disable-python-bindings \
- --enable-app \
- || return 1
- make || return 1
+ --enable-app
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="189f1e74972cec2684a0cbf27c144b03729c718032cbe61b0578979c8d14234c01da306c851aada12d00d255453dc180998e59016a22025de749bb2cfff220f0 nghttp2-1.20.0.tar.xz"
+sha512sums="55e7cad765d1f2f8e3211c20a8a316b6defebfe431f6c07ab81ed3dbe18bbf0eba8d6a980906b919a9e169568272f21e9eb946f6d555169085537f460dc35c4d nghttp2-1.21.0.tar.xz"