aboutsummaryrefslogtreecommitdiffstats
path: root/main/offlineimap
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-04-20 12:00:03 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-04-20 12:01:21 +0200
commitefd3fc99eda2cd0399aaf36fe649a6b6674fc160 (patch)
treedabce2f5beeb6ddac4ea3f2c226fafea813c9c59 /main/offlineimap
parent5589c4db5c2108b3a1456e99d7ca9b37be657d43 (diff)
downloadaports-efd3fc99eda2cd0399aaf36fe649a6b6674fc160.tar.bz2
aports-efd3fc99eda2cd0399aaf36fe649a6b6674fc160.tar.xz
main/offlineimap: moderinze APKBUILD
Diffstat (limited to 'main/offlineimap')
-rw-r--r--main/offlineimap/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/offlineimap/APKBUILD b/main/offlineimap/APKBUILD
index 310c9524da..e349a42e85 100644
--- a/main/offlineimap/APKBUILD
+++ b/main/offlineimap/APKBUILD
@@ -11,33 +11,34 @@ license="GPL2+"
depends="python2 py2-six"
makedepends="python2-dev asciidoc"
install=""
+options="!check"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/OfflineIMAP/${pkgname}/archive/v${pkgver}.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
cd "$builddir"/docs
- make man || return 1
+ make man
}
package() {
cd "$builddir"
python2 setup.py install --root="${pkgdir}" \
- --optimize=1 || return 1
+ --optimize=1
for man in docs/*.?; do
install -Dm644 "$man" \
- "$pkgdir"/usr/share/man/man${man##*.}/${man##*/} || return 1
+ "$pkgdir"/usr/share/man/man${man##*.}/${man##*/}
done
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
install -m644 README.md TODO.rst MAINTAINERS.rst Changelog.md \
- "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/
install -m644 offlineimap.conf* \
- "$pkgdir"/usr/share/doc/$pkgname/examples/ || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/examples/
}
sha512sums="9e9d5ea2b58dc212c9b69adb701fb4cd1ac1a7c8af90623dcfba3115ee7e1f63cc8569c352bae8f1fe09eb8c9255c39d0bf947dfb5d683ee4b03c0c822cb192d offlineimap-7.1.0.tar.gz"