aboutsummaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-02 15:32:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-02 15:32:49 +0000
commitf6a385f8b07c6b6c16fc026dffa0b29d097b785d (patch)
treec75c172975f5a36407386c4e6575f5d15792e4a6 /main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch
parentfdccff09e3ed4ded732b2d22d5d571642ad268bc (diff)
downloadaports-f6a385f8b07c6b6c16fc026dffa0b29d097b785d.tar.bz2
aports-f6a385f8b07c6b6c16fc026dffa0b29d097b785d.tar.xz
main/open-vm-tools: upgrade to 10.1.0 and enable -dbg
Diffstat (limited to 'main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch')
-rw-r--r--main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch96
1 files changed, 73 insertions, 23 deletions
diff --git a/main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch b/main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch
index ae1254249d..7cf86737a5 100644
--- a/main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch
+++ b/main/open-vm-tools/0010-Add-support-for-building-with-system-libtirpc.patch
@@ -1,7 +1,7 @@
-From 7d1329e9cdcae199789f7f37e6050d50d92a78b5 Mon Sep 17 00:00:00 2001
+From 89f0563609ac5f30e515a8b93aa2ccc5e98abadb Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 18 Nov 2015 09:54:42 +0000
-Subject: [PATCH 10/11] Add support for building with system libtirpc
+Subject: [PATCH 10/14] Add support for building with system libtirpc
This is needed for buliding with musl libc.
@@ -15,18 +15,21 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
open-vm-tools/lib/rpcChannel/Makefile.am | 4 ++++
open-vm-tools/lib/slashProc/Makefile.am | 4 ++++
open-vm-tools/libguestlib/Makefile.am | 2 ++
+ open-vm-tools/rpctool/Makefile.am | 3 +++
+ open-vm-tools/rpctool/rpctool.c | 2 ++
open-vm-tools/services/plugins/dndcp/Makefile.am | 2 ++
open-vm-tools/services/plugins/guestInfo/Makefile.am | 1 +
open-vm-tools/services/plugins/resolutionSet/Makefile.am | 2 ++
open-vm-tools/services/plugins/vix/Makefile.am | 2 ++
open-vm-tools/services/plugins/vmbackup/Makefile.am | 2 ++
- 13 files changed, 52 insertions(+), 1 deletion(-)
+ open-vm-tools/toolbox/Makefile.am | 2 ++
+ 16 files changed, 59 insertions(+), 1 deletion(-)
diff --git a/open-vm-tools/configure.ac b/open-vm-tools/configure.ac
-index f474150..d7d0e91 100644
+index b9f89115..a6312aa4 100644
--- a/open-vm-tools/configure.ac
+++ b/open-vm-tools/configure.ac
-@@ -380,6 +380,20 @@ AC_VMW_CHECK_LIB([fuse],
+@@ -405,6 +405,20 @@ AC_VMW_CHECK_LIB([fuse],
AC_MSG_WARN([Fuse is missing, vmblock-fuse/vmhgfs-fuse will be disabled.])])
#
@@ -48,7 +51,7 @@ index f474150..d7d0e91 100644
#
AC_ARG_WITH([pam],
diff --git a/open-vm-tools/lib/dynxdr/Makefile.am b/open-vm-tools/lib/dynxdr/Makefile.am
-index deb75e4..c6a285b 100644
+index 841c17db..5212f693 100644
--- a/open-vm-tools/lib/dynxdr/Makefile.am
+++ b/open-vm-tools/lib/dynxdr/Makefile.am
@@ -17,7 +17,13 @@
@@ -67,7 +70,7 @@ index deb75e4..c6a285b 100644
+libDynxdr_la_LIBADD += @LIBTIRPC_LIBS@
+
diff --git a/open-vm-tools/lib/guestRpc/Makefile.am b/open-vm-tools/lib/guestRpc/Makefile.am
-index d68bc07..cf75f0a 100644
+index 1605a27c..e37ecc7a 100644
--- a/open-vm-tools/lib/guestRpc/Makefile.am
+++ b/open-vm-tools/lib/guestRpc/Makefile.am
@@ -20,6 +20,12 @@ noinst_LTLIBRARIES = libGuestRpc.la
@@ -84,7 +87,7 @@ index d68bc07..cf75f0a 100644
# Problem is, $(CFLAGS) is appended to the compiler command line after AM_CFLAGS
# and after libGuestRpc_la_CFLAGS, so "-Wall -Werror" will override this flag.
diff --git a/open-vm-tools/lib/netUtil/Makefile.am b/open-vm-tools/lib/netUtil/Makefile.am
-index 6b13632..fcd5623 100644
+index eddc4ae0..fccc824f 100644
--- a/open-vm-tools/lib/netUtil/Makefile.am
+++ b/open-vm-tools/lib/netUtil/Makefile.am
@@ -20,3 +20,7 @@ noinst_LTLIBRARIES = libNetUtil.la
@@ -96,7 +99,7 @@ index 6b13632..fcd5623 100644
+
+libNetUtil_la_LIBADD = @LIBTIRPC_LIBS@
diff --git a/open-vm-tools/lib/nicInfo/Makefile.am b/open-vm-tools/lib/nicInfo/Makefile.am
-index ff59606..7d78358 100644
+index de09172b..ddc44dda 100644
--- a/open-vm-tools/lib/nicInfo/Makefile.am
+++ b/open-vm-tools/lib/nicInfo/Makefile.am
@@ -25,12 +25,14 @@ libNicInfo_la_SOURCES += nicInfoPosix.c
@@ -115,7 +118,7 @@ index ff59606..7d78358 100644
libNicInfo_la_LIBADD += @DNET_LIBS@
endif
diff --git a/open-vm-tools/lib/rpcChannel/Makefile.am b/open-vm-tools/lib/rpcChannel/Makefile.am
-index 32a9f8c..4497cce 100644
+index 4577b655..457f1938 100644
--- a/open-vm-tools/lib/rpcChannel/Makefile.am
+++ b/open-vm-tools/lib/rpcChannel/Makefile.am
@@ -27,3 +27,7 @@ endif
@@ -127,7 +130,7 @@ index 32a9f8c..4497cce 100644
+libRpcChannel_la_LIBADD =
+libRpcChannel_la_LIBADD += @LIBTIRPC_LIBS@
diff --git a/open-vm-tools/lib/slashProc/Makefile.am b/open-vm-tools/lib/slashProc/Makefile.am
-index e78988b..6026014 100644
+index b3afe9e5..8220f5f8 100644
--- a/open-vm-tools/lib/slashProc/Makefile.am
+++ b/open-vm-tools/lib/slashProc/Makefile.am
@@ -22,6 +22,10 @@ libSlashProc_la_SOURCES += net.c
@@ -142,10 +145,10 @@ index e78988b..6026014 100644
AM_CFLAGS = $(DNET_CPPFLAGS)
diff --git a/open-vm-tools/libguestlib/Makefile.am b/open-vm-tools/libguestlib/Makefile.am
-index b05d43a..a6b7c0b 100644
+index b49af696..393f5c13 100644
--- a/open-vm-tools/libguestlib/Makefile.am
+++ b/open-vm-tools/libguestlib/Makefile.am
-@@ -22,6 +22,7 @@ AM_CFLAGS += -I$(top_builddir)/include
+@@ -22,6 +22,7 @@ AM_CFLAGS += -I$(top_srcdir)/include
libguestlib_la_LIBADD =
libguestlib_la_LIBADD += @VMTOOLS_LIBS@
@@ -161,28 +164,59 @@ index b05d43a..a6b7c0b 100644
EXTRA_DIST = vmguestlib.pc.in
+diff --git a/open-vm-tools/rpctool/Makefile.am b/open-vm-tools/rpctool/Makefile.am
+index cb05cf8a..03d65285 100644
+--- a/open-vm-tools/rpctool/Makefile.am
++++ b/open-vm-tools/rpctool/Makefile.am
+@@ -17,10 +17,13 @@
+
+ bin_PROGRAMS = vmware-rpctool
+
++vmware_rpctool_CFLAGS= @LIBTIRPC_LIBS@
++
+ vmware_rpctool_SOURCES =
+ vmware_rpctool_SOURCES += rpctool.c
+
+ vmware_rpctool_LDADD =
++vmware_rpctool_LDADD += @LIBTIRPC_LIBS@
+ vmware_rpctool_LDADD += ../lib/rpcOut/libRpcOut.la
+ vmware_rpctool_LDADD += ../lib/message/libMessage.la
+ vmware_rpctool_LDADD += ../lib/backdoor/libBackdoor.la
+diff --git a/open-vm-tools/rpctool/rpctool.c b/open-vm-tools/rpctool/rpctool.c
+index f1528948..448d3328 100644
+--- a/open-vm-tools/rpctool/rpctool.c
++++ b/open-vm-tools/rpctool/rpctool.c
+@@ -23,6 +23,8 @@
+ */
+
+ #ifndef _WIN32
++#define _GNU_SOURCE
++#include <signal.h>
+ #include "sigPosixRegs.h"
+ #include <errno.h>
+ #include <stdint.h>
diff --git a/open-vm-tools/services/plugins/dndcp/Makefile.am b/open-vm-tools/services/plugins/dndcp/Makefile.am
-index 37e23c8..c00b77c 100644
+index d1543054..21209c8c 100644
--- a/open-vm-tools/services/plugins/dndcp/Makefile.am
+++ b/open-vm-tools/services/plugins/dndcp/Makefile.am
-@@ -22,6 +22,7 @@ libdndcp_la_CPPFLAGS =
+@@ -23,6 +23,7 @@ plugin_LTLIBRARIES = libdndcp.la
+ libdndcp_la_CPPFLAGS =
libdndcp_la_CPPFLAGS += @GTK_CPPFLAGS@
- libdndcp_la_CPPFLAGS += @GTKMM_CPPFLAGS@
libdndcp_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
+libdndcp_la_CPPFLAGS += @LIBTIRPC_CPPFLAGS@
libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/dnd
libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/dndGuest
libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/stringxx
-@@ -37,6 +38,7 @@ libdndcp_la_LIBADD += @GTK_LIBS@
+@@ -44,6 +45,7 @@ libdndcp_la_LIBADD += @GTK_LIBS@
libdndcp_la_LIBADD += @GTKMM_LIBS@
libdndcp_la_LIBADD += @VMTOOLS_LIBS@
libdndcp_la_LIBADD += @HGFS_LIBS@
+libdndcp_la_LIBADD += @LIBTIRPC_LIBS@
+ libdndcp_la_LIBADD += $(top_builddir)/lib/hgfsUri/hgfsUriPosix.lo
libdndcp_la_SOURCES =
-
diff --git a/open-vm-tools/services/plugins/guestInfo/Makefile.am b/open-vm-tools/services/plugins/guestInfo/Makefile.am
-index 4ac05f4..8528238 100644
+index 4400e5a1..419bab08 100644
--- a/open-vm-tools/services/plugins/guestInfo/Makefile.am
+++ b/open-vm-tools/services/plugins/guestInfo/Makefile.am
@@ -22,6 +22,7 @@ plugin_LTLIBRARIES = libguestInfo.la
@@ -194,7 +228,7 @@ index 4ac05f4..8528238 100644
libguestInfo_la_LDFLAGS =
libguestInfo_la_LDFLAGS += @PLUGIN_LDFLAGS@
diff --git a/open-vm-tools/services/plugins/resolutionSet/Makefile.am b/open-vm-tools/services/plugins/resolutionSet/Makefile.am
-index 75432d7..9303b25 100644
+index 3d8dbc4f..1d057c63 100644
--- a/open-vm-tools/services/plugins/resolutionSet/Makefile.am
+++ b/open-vm-tools/services/plugins/resolutionSet/Makefile.am
@@ -21,6 +21,7 @@ plugin_LTLIBRARIES = libresolutionSet.la
@@ -214,7 +248,7 @@ index 75432d7..9303b25 100644
libresolutionSet_la_SOURCES =
libresolutionSet_la_SOURCES += libvmwarectrl.c
diff --git a/open-vm-tools/services/plugins/vix/Makefile.am b/open-vm-tools/services/plugins/vix/Makefile.am
-index b19a15d..02996d2 100644
+index f7d541e5..af4e0a55 100644
--- a/open-vm-tools/services/plugins/vix/Makefile.am
+++ b/open-vm-tools/services/plugins/vix/Makefile.am
@@ -20,6 +20,7 @@ plugin_LTLIBRARIES = libvix.la
@@ -234,7 +268,7 @@ index b19a15d..02996d2 100644
libvix_la_LIBADD += $(top_builddir)/lib/foundryMsg/libFoundryMsg.la
libvix_la_LIBADD += $(top_builddir)/lib/impersonate/libImpersonate.la
diff --git a/open-vm-tools/services/plugins/vmbackup/Makefile.am b/open-vm-tools/services/plugins/vmbackup/Makefile.am
-index 99589bf..1cfa007 100644
+index 81fc5c7f..00224f65 100644
--- a/open-vm-tools/services/plugins/vmbackup/Makefile.am
+++ b/open-vm-tools/services/plugins/vmbackup/Makefile.am
@@ -20,6 +20,7 @@ plugin_LTLIBRARIES = libvmbackup.la
@@ -253,6 +287,22 @@ index 99589bf..1cfa007 100644
libvmbackup_la_SOURCES =
libvmbackup_la_SOURCES += nullProvider.c
+diff --git a/open-vm-tools/toolbox/Makefile.am b/open-vm-tools/toolbox/Makefile.am
+index 66d36ac6..2becd3c7 100644
+--- a/open-vm-tools/toolbox/Makefile.am
++++ b/open-vm-tools/toolbox/Makefile.am
+@@ -20,9 +20,11 @@ bin_PROGRAMS = vmware-toolbox-cmd
+ vmware_toolbox_cmd_LDADD =
+ vmware_toolbox_cmd_LDADD += ../libguestlib/libguestlib.la
+ vmware_toolbox_cmd_LDADD += @VMTOOLS_LIBS@
++vmware_toolbox_cmd_LDADD += @LIBTIRPC_LIBS@
+
+ vmware_toolbox_cmd_CPPFLAGS =
+ vmware_toolbox_cmd_CPPFLAGS += @VMTOOLS_CPPFLAGS@
++vmware_toolbox_cmd_CPPFLAGS += @LIBTIRPC_CPPFLAGS@
+
+ vmware_toolbox_cmd_SOURCES =
+ vmware_toolbox_cmd_SOURCES += toolbox-cmd.c
--
-2.6.3
+2.11.0