aboutsummaryrefslogtreecommitdiffstats
path: root/main/opennhrp
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-10-18 11:04:21 -0400
committerTimo Teräs <timo.teras@iki.fi>2011-10-18 11:04:21 -0400
commit698fb0d1f0539bc480c188a08d54c42de8d55f4d (patch)
tree1ad5613ddcfb1c7353da9299c77d2e5fe3d2c960 /main/opennhrp
parent4046ce09e28d0f0c76b5b977e9d0c2ec2e445a54 (diff)
downloadaports-698fb0d1f0539bc480c188a08d54c42de8d55f4d.tar.bz2
aports-698fb0d1f0539bc480c188a08d54c42de8d55f4d.tar.xz
main/opennhrp: apply shortcut-target holding-time bugfix from upstream
Diffstat (limited to 'main/opennhrp')
-rw-r--r--main/opennhrp/0001-config-really-fix-holding-time-to-apply-to-shortcut-.patch39
-rw-r--r--main/opennhrp/APKBUILD4
2 files changed, 42 insertions, 1 deletions
diff --git a/main/opennhrp/0001-config-really-fix-holding-time-to-apply-to-shortcut-.patch b/main/opennhrp/0001-config-really-fix-holding-time-to-apply-to-shortcut-.patch
new file mode 100644
index 0000000000..da1e8ffefa
--- /dev/null
+++ b/main/opennhrp/0001-config-really-fix-holding-time-to-apply-to-shortcut-.patch
@@ -0,0 +1,39 @@
+From 3554acce7fec0ce6e7560444c5e3975affb78260 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Tue, 18 Oct 2011 10:56:16 -0400
+Subject: [PATCH] config: really fix holding-time to apply to shortcut-target
+
+commit 94d1a7d4884346a5ba830ac209e1b746d23ec0c1 was supposed to
+fix it, but it didn't fix resetting of the peer variable properly.
+---
+ nhrp/opennhrp.c | 9 +++++----
+ 1 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/nhrp/opennhrp.c b/nhrp/opennhrp.c
+index f2ecd44..0ff34ea 100644
+--- a/nhrp/opennhrp.c
++++ b/nhrp/opennhrp.c
+@@ -243,15 +243,16 @@ static int load_config(const char *config_file)
+ NEED_PEER();
+ peer->flags |= NHRP_PEER_FLAG_CISCO;
+ } else if (strcmp(word, "holding-time") == 0) {
+- peer = NULL;
+ read_word(in, &lineno, sizeof(word), word);
+ if (peer != NULL &&
+- peer->type == NHRP_PEER_TYPE_LOCAL_ADDR)
++ peer->type == NHRP_PEER_TYPE_LOCAL_ADDR) {
+ peer->holding_time = atoi(word);
+- else if (iface != NULL)
++ } else if (iface != NULL) {
+ iface->holding_time = atoi(word);
+- else
++ peer = NULL;
++ } else {
+ rc = 7;
++ }
+ } else if (strcmp(word, "cisco-authentication") == 0) {
+ struct nhrp_buffer *buf;
+ struct nhrp_cisco_authentication_extension *auth;
+--
+1.7.4.1
+
diff --git a/main/opennhrp/APKBUILD b/main/opennhrp/APKBUILD
index da777e2337..b2daec0530 100644
--- a/main/opennhrp/APKBUILD
+++ b/main/opennhrp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=opennhrp
pkgver=0.12.3
-pkgrel=0
+pkgrel=1
pkgdesc="NBMA Next Hop Resolution Protocol daemon"
url="http://sourceforge.net/projects/opennhrp"
arch="all"
@@ -11,6 +11,7 @@ makedepends="c-ares-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
opennhrp-0.9.3-peer-up-bgp.patch
+ 0001-config-really-fix-holding-time-to-apply-to-shortcut-.patch
$pkgname.initd
$pkgname.confd
"
@@ -34,5 +35,6 @@ package() {
}
md5sums="4d0ec7c0282e181ecca4d78e52067da3 opennhrp-0.12.3.tar.bz2
f81539fc92800bb79668dda119a97d1d opennhrp-0.9.3-peer-up-bgp.patch
+884c085eedace7eab4d65ae3a47c4bde 0001-config-really-fix-holding-time-to-apply-to-shortcut-.patch
ae65f88ccf849ef882669a8b4f0c7fc0 opennhrp.initd
8eee86233728dc0d156bbfee6d98f338 opennhrp.confd"