aboutsummaryrefslogtreecommitdiffstats
path: root/main/opennhrp
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-03-24 08:10:25 +0200
committerTimo Teräs <timo.teras@iki.fi>2011-03-24 08:10:25 +0200
commite07c41dd8355b0add721ddc940f28056d531a772 (patch)
tree8407f80f651e3aee9c8b9683beaa193b66df477a /main/opennhrp
parent3cdc1241a4baf9638ac9eb92d1f709e3884e4cbb (diff)
downloadaports-e07c41dd8355b0add721ddc940f28056d531a772.tar.bz2
aports-e07c41dd8355b0add721ddc940f28056d531a772.tar.xz
main/opennhrp: update to 0.12.1
* remove patch found in upstream * update license to GPL-2, it was changed quite some time ago in upstream from GPL-3 to "GPL-2 or later"
Diffstat (limited to 'main/opennhrp')
-rw-r--r--main/opennhrp/APKBUILD10
-rw-r--r--main/opennhrp/fix-holding-time.patch31
2 files changed, 4 insertions, 37 deletions
diff --git a/main/opennhrp/APKBUILD b/main/opennhrp/APKBUILD
index 0f89f777f0..02dc7f6245 100644
--- a/main/opennhrp/APKBUILD
+++ b/main/opennhrp/APKBUILD
@@ -1,17 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=opennhrp
-pkgver=0.12
-pkgrel=1
+pkgver=0.12.1
+pkgrel=0
pkgdesc="NBMA Next Hop Resolution Protocol daemon"
url="http://sourceforge.net/projects/opennhrp"
arch="all"
-license="GPL-3"
+license="GPL-2"
depends=
makedepends="c-ares-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
opennhrp-0.9.3-peer-up-bgp.patch
- fix-holding-time.patch
$pkgname.initd
$pkgname.confd
"
@@ -33,8 +32,7 @@ package() {
install -Dm755 "$srcdir"/opennhrp.initd "$pkgdir"/etc/init.d/opennhrp
install -Dm644 "$srcdir"/opennhrp.confd "$pkgdir"/etc/conf.d/opennhrp
}
-md5sums="864e4253a0673bb6dcd6dd60ae5d69df opennhrp-0.12.tar.bz2
+md5sums="31ada6dede3c62dac491002624d34778 opennhrp-0.12.1.tar.bz2
f81539fc92800bb79668dda119a97d1d opennhrp-0.9.3-peer-up-bgp.patch
-87a9fce5fb62beeae927d4216e341ea1 fix-holding-time.patch
ae65f88ccf849ef882669a8b4f0c7fc0 opennhrp.initd
8eee86233728dc0d156bbfee6d98f338 opennhrp.confd"
diff --git a/main/opennhrp/fix-holding-time.patch b/main/opennhrp/fix-holding-time.patch
deleted file mode 100644
index 3aee17dc05..0000000000
--- a/main/opennhrp/fix-holding-time.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Timo Teräs <timo.teras@iki.fi>
-Date: Wed, 3 Nov 2010 07:03:53 +0000 (+0200)
-Subject: config: fix holding-time to apply to shortcut-target
-X-Git-Url: http://opennhrp.git.sourceforge.net/git/gitweb.cgi?p=opennhrp%2Fopennhrp;a=commitdiff_plain;h=94d1a7d;hp=f9b92c4dcb162670c5cd2226b40e0446c9d3c63a
-
-config: fix holding-time to apply to shortcut-target
-
-Fix the order of object checks to make the keyword apply
-to shortcut-target if in such context, and only after that
-to interface context.
----
-
-diff --git a/nhrp/opennhrp.c b/nhrp/opennhrp.c
-index 053de99..f2ecd44 100644
---- a/nhrp/opennhrp.c
-+++ b/nhrp/opennhrp.c
-@@ -245,11 +245,11 @@ static int load_config(const char *config_file)
- } else if (strcmp(word, "holding-time") == 0) {
- peer = NULL;
- read_word(in, &lineno, sizeof(word), word);
-- if (iface != NULL)
-- iface->holding_time = atoi(word);
-- else if (peer != NULL &&
-+ if (peer != NULL &&
- peer->type == NHRP_PEER_TYPE_LOCAL_ADDR)
- peer->holding_time = atoi(word);
-+ else if (iface != NULL)
-+ iface->holding_time = atoi(word);
- else
- rc = 7;
- } else if (strcmp(word, "cisco-authentication") == 0) {