aboutsummaryrefslogtreecommitdiffstats
path: root/main/openntpd
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-30 14:26:39 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-30 14:27:11 +0200
commit84e9e495e7130b0d6dd306ae0e98646f2e2de197 (patch)
tree9d8a18181ee2b0d0a085a42034a8fd161254421c /main/openntpd
parentb92cb9f82e9db0b62f2d9c49945954969e5b5c1f (diff)
downloadaports-84e9e495e7130b0d6dd306ae0e98646f2e2de197.tar.bz2
aports-84e9e495e7130b0d6dd306ae0e98646f2e2de197.tar.xz
main/openntpd: upgrade to 6.2_p2
Diffstat (limited to 'main/openntpd')
-rw-r--r--main/openntpd/APKBUILD8
-rw-r--r--main/openntpd/fix-__dead-macro.patch86
2 files changed, 91 insertions, 3 deletions
diff --git a/main/openntpd/APKBUILD b/main/openntpd/APKBUILD
index 425ebfde4d..9954bc671f 100644
--- a/main/openntpd/APKBUILD
+++ b/main/openntpd/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openntpd
-pkgver=6.0_p1
+pkgver=6.2_p2
_pkgver=${pkgver/_/}
-pkgrel=5
+pkgrel=0
pkgdesc="Lightweight NTP server ported from OpenBSD"
url="http://www.openntpd.org/"
subpackages="openntpd-doc"
@@ -12,6 +12,7 @@ license="BSD"
options="!check"
source="http://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/$pkgname-$_pkgver.tar.gz
ntp-user.patch
+ fix-__dead-macro.patch
$pkgname.confd
$pkgname.initd
"
@@ -44,7 +45,8 @@ package() {
rmdir "$pkgdir"/var/run
}
-sha512sums="a71c516dbe7596cbcb3a385112a59a82185b7e3d93a52eda695cea5a0a599ba7fbf58daa81da55d608255cb6950398123fa7d71663604a4c3bcbee949711296d openntpd-6.0p1.tar.gz
+sha512sums="b8559aa8ceaf796a94a21f8a6d4dfd2edfdc4587845c73cd6d27c81d200355c3e40e72644b3a558e9bfe4fd0d2aafae98b50c581e67ac72eec53eeeabd9cb882 openntpd-6.2p2.tar.gz
290311e5cd074d5bd1e6374ba9b4776e4acf792d47011c43412e236766b73be2b0e5f0091bd3ad79d0b637754531889b199e66c64952765bbcd1bade0d2ebe94 ntp-user.patch
+388895fd07745c43b5ac0683f72154ebdc398e245d8cd0743a8af2cfca2995a01f4d459e1f1a0cb4a0d1e49b92c96f365427dee307104b19268c74ed836a7f92 fix-__dead-macro.patch
01c3d9ed18741981fb2d8ebb509cd71801b57f57fcac48ed727687a6402dbad8a791ace1e63c0069a07b0dbcbc98c917885c942dab9616d25dde429f1fb9c348 openntpd.confd
009eb7c7cf290c9302d9585ce7dffb2195e7e73c8bd3274b158efde10b537919c5dc4a47038f2fca6d650bcd79e8333395faa06d98f28327a328368fd59a1618 openntpd.initd"
diff --git a/main/openntpd/fix-__dead-macro.patch b/main/openntpd/fix-__dead-macro.patch
new file mode 100644
index 0000000000..56e711da79
--- /dev/null
+++ b/main/openntpd/fix-__dead-macro.patch
@@ -0,0 +1,86 @@
+From 17aa5d98191c4dc85d0645443fc97a12601ae8da Mon Sep 17 00:00:00 2001
+From: Baruch Siach <baruch@tkos.co.il>
+Date: Tue, 26 Sep 2017 14:55:31 +0300
+Subject: [PATCH] Revert "use __dead macro from sys/cdefs.h"
+
+This partially reverts commit a7577667d673f49800e15461fe384817a1572eae.
+
+The musl C library does not use an internal cdefs.h header. As a result,
+the definitions in sys/cdefs.h have no effect. This breads the build as
+follows:
+
+In file included from adjfreq_linux.c:23:0:
+../src/ntpd.h:448:8: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
+ __dead void fatal(const char *, ...)
+ ^~~~
+../src/ntpd.h:450:8: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
+ __dead void fatalx(const char *, ...)
+ ^~~~
+
+Refer the related musl FAQ about cdefs.h:
+
+ http://wiki.musl-libc.org/wiki/FAQ#Q:_I.27m_trying_to_compile_something_against_musl_and_I_get_error_messages_about_sys.2Fcdefs.h
+
+Keep the compiler attribute definition.
+
+Remove also from noinst_HEADERS.
+
+diff --git a/include/Makefile.am b/include/Makefile.am
+index a552026..3a5a016 100644
+--- a/include/Makefile.am
++++ b/include/Makefile.am
+@@ -1,6 +1,5 @@
+ noinst_HEADERS =
+ noinst_HEADERS += machine/endian.h
+-noinst_HEADERS += sys/cdefs.h
+ noinst_HEADERS += sys/queue.h
+ noinst_HEADERS += sys/socket.h
+ noinst_HEADERS += sys/types.h
+diff --git a/include/sys/cdefs.h b/include/sys/cdefs.h
+deleted file mode 100644
+index 3dec43d..0000000
+--- a/include/sys/cdefs.h
++++ /dev/null
+@@ -1,16 +0,0 @@
+-/*
+- * Public domain
+- * sys/cdefs.h compatibility shim
+- */
+-
+-#include_next <sys/cdefs.h>
+-
+-#ifndef LIBCOMPAT_SYS_CDEFS_H
+-#define LIBCOMPAT_SYS_CDEFS_H
+-
+-#if !defined(HAVE_ATTRIBUTE__DEAD) && !defined(__dead)
+-#define __dead __attribute__((__noreturn__))
+-#define __pure __attribute__((__const__))
+-#endif
+-
+-#endif
+diff --git a/include/sys/types.h b/include/sys/types.h
+index 56aef0b..86821c7 100644
+--- a/include/sys/types.h
++++ b/include/sys/types.h
+@@ -14,6 +14,10 @@
+ #include <_bsd_types.h>
+ #endif
+
++#if !defined(HAVE_ATTRIBUTE__DEAD) && !defined(__dead)
++#define __dead __attribute__((__noreturn__))
++#endif
++
+ #if !defined(HAVE_ATTRIBUTE__BOUNDED__) && !defined(__bounded__)
+ # define __bounded__(x, y, z)
+ #endif
+--- a/include/Makefile.in
++++ b/include/Makefile.in
+@@ -264,7 +264,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-noinst_HEADERS = machine/endian.h sys/cdefs.h sys/queue.h sys/socket.h \
++noinst_HEADERS = machine/endian.h sys/queue.h sys/socket.h \
+ sys/types.h sys/time.h sys/mman.h sys/wait.h err.h ifaddrs.h \
+ imsg.h md5.h sha2.h signal.h sha2_openbsd.h Makefile.in \
+ paths.h poll.h stdio.h stdlib.h string.h time.h tls.h unistd.h