aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-extutils-config
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-31 10:24:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-31 10:24:16 +0000
commit95ccda45456fef1c836263890e2861a06ae1a99c (patch)
tree5b7b138fa81ebaf5b4910e2277e58be8ef7b63c5 /main/perl-extutils-config
parent3bb53d7e35c835d6a1bed85df2632ca8d5084cf6 (diff)
downloadaports-95ccda45456fef1c836263890e2861a06ae1a99c.tar.bz2
aports-95ccda45456fef1c836263890e2861a06ae1a99c.tar.xz
main/perl-extutils-config: move from testing
Diffstat (limited to 'main/perl-extutils-config')
-rw-r--r--main/perl-extutils-config/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-extutils-config/APKBUILD b/main/perl-extutils-config/APKBUILD
new file mode 100644
index 0000000000..4dce8caebd
--- /dev/null
+++ b/main/perl-extutils-config/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-extutils-config
+_pkgreal=ExtUtils-Config
+pkgver=0.007
+pkgrel=0
+pkgdesc="A wrapper for perl's configuration"
+url="http://search.cpan.org/dist/ExtUtils-Config/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="2829c0dfa8a7e51b3f582efbee4bb128 ExtUtils-Config-0.007.tar.gz"
+sha256sums="2c1465078b876fd16a90507092805265528c2532d4937b03547a6dbdb8ac0eef ExtUtils-Config-0.007.tar.gz"
+sha512sums="168facb55560ad562bf1e4ca59dd0cee119e0059a8ac7d62283b7074078f73aabd5cc8c217754492a1e0bae61456b9ed9480f9710fbddd3865e5eddaf746052f ExtUtils-Config-0.007.tar.gz"