aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-module-install/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-10 10:37:22 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-10 11:07:43 +0000
commitc4ef2df31b0d5f92ad0292d7fc9b50324ccb2a54 (patch)
tree21caeea5a93f27ecf348a3f32e11a5e087b6efb6 /main/perl-module-install/APKBUILD
parentf4c0b6c314e263ff14919ba1863addda3abb3d21 (diff)
downloadaports-c4ef2df31b0d5f92ad0292d7fc9b50324ccb2a54.tar.bz2
aports-c4ef2df31b0d5f92ad0292d7fc9b50324ccb2a54.tar.xz
community/perl-module-install: move to main
Diffstat (limited to 'main/perl-module-install/APKBUILD')
-rw-r--r--main/perl-module-install/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/perl-module-install/APKBUILD b/main/perl-module-install/APKBUILD
new file mode 100644
index 0000000000..4ff632968a
--- /dev/null
+++ b/main/perl-module-install/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-module-install
+_pkgreal=Module-Install
+pkgver=1.18
+pkgrel=0
+pkgdesc="Perl module for Module-Install"
+url="http://search.cpan.org/dist/Module-Install/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpanmakedepends="perl-file-remove perl-module-build perl-module-scandeps perl-yaml-tiny"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+prepare() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="2126d35c9bab151548551629e6a470f9a7b90fd901f32cdc15e9aa83b931178f99e28e2de32ce7b8a677d187474efc428839d7e7254074f26fcfcfe18fa297a9 Module-Install-1.18.tar.gz"