aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-pylast
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-04-10 09:30:48 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-04-10 09:30:55 +0200
commit296364e3320181a6d7a3070cdb7d055e01ede368 (patch)
tree48ddb37477ded84e270099dc3fdbb23cd2e10473 /main/py-pylast
parent80a59fd6c81780ef0ab680dfd40ff22630d3555b (diff)
downloadaports-296364e3320181a6d7a3070cdb7d055e01ede368.tar.bz2
aports-296364e3320181a6d7a3070cdb7d055e01ede368.tar.xz
main/py-pylast: move to main and upgrade to 1.1.0
Diffstat (limited to 'main/py-pylast')
-rw-r--r--main/py-pylast/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/py-pylast/APKBUILD b/main/py-pylast/APKBUILD
new file mode 100644
index 0000000000..3725630d12
--- /dev/null
+++ b/main/py-pylast/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-pylast
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="A Python interface to the last.fm API"
+url="https://github.com/pylast/pylast"
+arch="noarch"
+license="Apache"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/p/pylast/pylast-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pylast-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a8529f07bb6c935777236affd67ea976 pylast-1.1.0.tar.gz"
+sha256sums="f7da6f8f5c02bff18e4600ad7d44b7d82cbf78d3a9b09c33e168def4280953ce pylast-1.1.0.tar.gz"
+sha512sums="61fd99597582b14b62e8c931a68d296a5a30dfc732112ee5fca6c7061f7a4fa391ea76520699278d89d2ee121dfbf1805eb925c176fc48704add8374fceb95ab pylast-1.1.0.tar.gz"