aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-six
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-01 23:25:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-01 23:27:00 +0200
commit47852ba6d71c4038c8efcf71020ffc089a704fa0 (patch)
tree06fd49702c6bac18fb78aa6cc465004e9222eb3c /main/py-six
parent7364456d18ae3db285274fa264ed8a2632851117 (diff)
downloadaports-47852ba6d71c4038c8efcf71020ffc089a704fa0.tar.bz2
aports-47852ba6d71c4038c8efcf71020ffc089a704fa0.tar.xz
main/py-six: improve abuild and fix to not silently fail
Diffstat (limited to 'main/py-six')
-rw-r--r--main/py-six/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/main/py-six/APKBUILD b/main/py-six/APKBUILD
index 61089e6f8e..9216bb434c 100644
--- a/main/py-six/APKBUILD
+++ b/main/py-six/APKBUILD
@@ -3,23 +3,21 @@
pkgname=py-six
_pkgname=six
pkgver=1.10.0
-pkgrel=4
+pkgrel=5
pkgdesc="Python 2 and 3 compatibility library"
url="http://pypi.python.org/pypi/six"
arch="noarch"
license="MIT"
depends=""
-depends_dev=""
makedepends="python2-dev python3-dev py-setuptools"
-install=""
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
@@ -27,23 +25,24 @@ package() {
}
_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
_py2() {
- _py python2
replaces="$pkgname"
+ _py python2
}
_py3() {
_py python3
}
-
md5sums="34eed507548117b2ab523ab14b2f8b55 six-1.10.0.tar.gz"
sha256sums="105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a six-1.10.0.tar.gz"
sha512sums="9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e six-1.10.0.tar.gz"