aboutsummaryrefslogtreecommitdiffstats
path: root/main/randrproto
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-03 14:35:58 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:51:28 +0000
commit0bf5dbbbfbe7f87b06f5d7823557ed652c008e39 (patch)
tree8269fd0a2806ea5a95ae40ced406ffda58b698fd /main/randrproto
parent7ee65942380b66ea5807666d26c2e4ddb4215e00 (diff)
downloadaports-0bf5dbbbfbe7f87b06f5d7823557ed652c008e39.tar.bz2
aports-0bf5dbbbfbe7f87b06f5d7823557ed652c008e39.tar.xz
main/randrproto: modernise, add -doc, mark as having no test suite
Diffstat (limited to 'main/randrproto')
-rw-r--r--main/randrproto/APKBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/main/randrproto/APKBUILD b/main/randrproto/APKBUILD
index d4c4da7936..540b34f788 100644
--- a/main/randrproto/APKBUILD
+++ b/main/randrproto/APKBUILD
@@ -1,34 +1,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=randrproto
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="X11 RandR extension wire protocol"
url="http://xorg.freedesktop.org/"
-arch="all"
+arch="noarch"
license="custom"
depends=""
-makedepends=""
+makedepends="util-macros"
+options="!check" # No test suite
+subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$_builddir"
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -d -m755 "$pkgdir"/usr/share/licenses/$pkgname
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}