aboutsummaryrefslogtreecommitdiffstats
path: root/main/ruby/APKBUILD
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-22 22:05:17 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 01:39:44 +0100
commit9e029de2c6353726de596359af6b42ae65a13f93 (patch)
treeed5bf5944560383a1bf2f77a07e2fb2a9dfb89bb /main/ruby/APKBUILD
parent78cb6c350e4224f5257aedbb30442520a0ad0a3c (diff)
downloadaports-9e029de2c6353726de596359af6b42ae65a13f93.tar.bz2
aports-9e029de2c6353726de596359af6b42ae65a13f93.tar.xz
main/ruby: do not fail on file removal
With the new abuild version, ruby is not able to build because it tries to remove some files that might not exist, returning error. This patch does not cause rm to fail if the files do not exist.
Diffstat (limited to 'main/ruby/APKBUILD')
-rw-r--r--main/ruby/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index 365a67ef68..d0d5b2fce9 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -94,7 +94,7 @@ package() {
rm -R "$pkgdir"$_gemdir/cache/*
# Remove bundled CA certificates.
- rm -R "$pkgdir"$_rubydir/rubygems/ssl_certs/*.pem
+ rm -R "$pkgdir"$_rubydir/rubygems/ssl_certs/*.pem || true
if [ -d "$pkgdir"/usr/local ]; then
local f=$(cd "$pkgdir" ; find usr/local -type f)