aboutsummaryrefslogtreecommitdiffstats
path: root/main/sed
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 14:30:17 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-12 15:05:06 +0000
commit08a796d83545e758eec24f38d552b7b9db0ed51a (patch)
treef1baaa63cec9d999eede92c8184081cdbf2341f5 /main/sed
parentdba7e819d369839f8db5f6514ea42073fcacfdd9 (diff)
downloadaports-08a796d83545e758eec24f38d552b7b9db0ed51a.tar.bz2
aports-08a796d83545e758eec24f38d552b7b9db0ed51a.tar.xz
main/sed: add check, fix license
Diffstat (limited to 'main/sed')
-rw-r--r--main/sed/APKBUILD22
-rw-r--r--main/sed/disable-mbrtowc-test.patch10
-rw-r--r--main/sed/localename-test-fix.patch34
3 files changed, 61 insertions, 5 deletions
diff --git a/main/sed/APKBUILD b/main/sed/APKBUILD
index 8b397ee11f..3e2ea4717c 100644
--- a/main/sed/APKBUILD
+++ b/main/sed/APKBUILD
@@ -1,15 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sed
pkgver=4.4
-pkgrel=1
+pkgrel=2
subpackages="$pkgname-doc"
pkgdesc="GNU stream editor"
url="https://www.gnu.org/software/sed"
arch="all"
-license="GPL"
+options="!checkroot"
+license="GPL-3.0+"
makedepends="perl"
+checkdepends="diffutils"
install="$pkgname.post-deinstall"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz"
+source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ disable-mbrtowc-test.patch
+ localename-test-fix.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
@@ -27,12 +32,19 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/lib/charset.alias
+ rm -rf "$pkgdir"/usr/lib/charset.alias || true
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
-sha512sums="4e1b0a7403913f1e25047eb2292a0a9b3488b15b4463ce2803e05eaecbc2da19f477a18e6a70c992461c38ced90774415091aa2d8ce85cb74e391610d9eedb70 sed-4.4.tar.xz"
+sha512sums="4e1b0a7403913f1e25047eb2292a0a9b3488b15b4463ce2803e05eaecbc2da19f477a18e6a70c992461c38ced90774415091aa2d8ce85cb74e391610d9eedb70 sed-4.4.tar.xz
+aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch
+3fbf7f5fbdef19f1212c4efad560b85e62744eecfe60eceaba1c8d093764f34bff844d31d704afdc064ca3d31bb7e46860a4b91e671b96930554a72953e88edf localename-test-fix.patch"
diff --git a/main/sed/disable-mbrtowc-test.patch b/main/sed/disable-mbrtowc-test.patch
new file mode 100644
index 0000000000..51cdf3c256
--- /dev/null
+++ b/main/sed/disable-mbrtowc-test.patch
@@ -0,0 +1,10 @@
+--- sed-4.4/gnulib-tests/test-mbrtowc5.sh.old 2016-12-31 13:54:43.000000000 +0000
++++ sed-4.4/gnulib-tests/test-mbrtowc5.sh 2017-07-30 17:29:50.879924130 +0000
+@@ -1,6 +1,2 @@
+ #!/bin/sh
+-# Test whether the POSIX locale has encoding errors.
+-LC_ALL=C \
+-./test-mbrtowc${EXEEXT} 5 || exit
+-LC_ALL=POSIX \
+-./test-mbrtowc${EXEEXT} 5
++exit 77
diff --git a/main/sed/localename-test-fix.patch b/main/sed/localename-test-fix.patch
new file mode 100644
index 0000000000..8a5d68dde3
--- /dev/null
+++ b/main/sed/localename-test-fix.patch
@@ -0,0 +1,34 @@
+--- sed-4.4/gnulib-tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
++++ sed-4.4/gnulib-tests/localename.c 2017-07-30 16:40:47.098541270 +0000
+@@ -40,7 +40,7 @@
+ # if defined __APPLE__ && defined __MACH__
+ # include <xlocale.h>
+ # endif
+-# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined __linux__
+ # include <langinfo.h>
+ # endif
+ # if !defined IN_LIBINTL
+@@ -2692,16 +2692,19 @@
+ locale_t thread_locale = uselocale (NULL);
+ if (thread_locale != LC_GLOBAL_LOCALE)
+ {
+-# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined(_NL_LOCALE_NAME)
++ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
++# if __GLIBC__ >= 2 && !defined __UCLIBC__
+ /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
+ glibc < 2.12.
+ See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
+- const char *name =
+- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
++ if (name[0] == '\0')
++ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
+ if (name[0] == '\0')
+ /* Fallback code for glibc < 2.4, which did not implement
+ nl_langinfo (_NL_LOCALE_NAME (category)). */
+ name = thread_locale->__names[category];
++# endif
+ return name;
+ # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
+ /* FreeBSD, Mac OS X */