aboutsummaryrefslogtreecommitdiffstats
path: root/main/sessreg/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-04-26 06:13:10 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-04-26 06:13:10 +0000
commitfd24b5926b3a965f9cca3aa0389feda568e86f03 (patch)
treed6670e4d4f8c7563f855d8fce195f13b16a16e38 /main/sessreg/APKBUILD
parent56aa0dca6788d52e68f5b2cab0320938b6b7a637 (diff)
downloadaports-fd24b5926b3a965f9cca3aa0389feda568e86f03.tar.bz2
aports-fd24b5926b3a965f9cca3aa0389feda568e86f03.tar.xz
main/sessreg: fixed builddir and added patch for utmp path
Diffstat (limited to 'main/sessreg/APKBUILD')
-rw-r--r--main/sessreg/APKBUILD30
1 files changed, 9 insertions, 21 deletions
diff --git a/main/sessreg/APKBUILD b/main/sessreg/APKBUILD
index 7fb1153b9a..17534e0864 100644
--- a/main/sessreg/APKBUILD
+++ b/main/sessreg/APKBUILD
@@ -1,33 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sessreg
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="manage utmp/wtmp entries for non-init clients"
url="http://xorg.freedesktop.org/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
depends=
-makedepends="xproto"
+makedepends="xproto bsd-compat-headers linux-headers"
source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2
-missing_path_wtmpx.patch
-"
+ missing_path_wtmpx.patch"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- patch*|*.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build () {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,12 +26,12 @@ build () {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="e238c89dabc566e1835e1ecb61b605b9 sessreg-1.1.0.tar.bz2
-d07d76587afb64739c876529c4f582cd missing_path_wtmpx.patch"
+6f55bfd9eb298ffde45d4e34e3c556db missing_path_wtmpx.patch"
sha256sums="551177657835e0902b5eee7b19713035beaa1581bbd3c6506baa553e751e017c sessreg-1.1.0.tar.bz2
-8d13a6ae41492cdc4afd38691f45792e8000b129f34e94cf83a30435c4686b29 missing_path_wtmpx.patch"
+67599b812be3faa2b3b15f2d6352930b34a26df2f30df3f1da4c96018da16fb9 missing_path_wtmpx.patch"
sha512sums="5d9010874696bbc53a6271f30c089690cb341ede992f6be0914474a03ff4468e01e6a4ce7e6a437b96751fdf0ccced52b374126e5caeac6747edecd049841116 sessreg-1.1.0.tar.bz2
-ab562bba2463d8f7ede6ed90fafdd685a33596ef47f118eefa2312f38e34d1ba18bd0c383dfe778327b126e0c80dc12045cb27d49eab09162ebacea6ab98b522 missing_path_wtmpx.patch"
+57a7dea5f0f9d8c3f54aa3aeb98f6fa8cd44e9d7397c81ad40e973ad3a548b7137a986bda6367df5d867d2b1e6d8eacdd182fcf920ea9d1e8c70cc64f40651df missing_path_wtmpx.patch"