aboutsummaryrefslogtreecommitdiffstats
path: root/main/shorewall-core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-03 06:24:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-03 06:49:46 +0000
commit681f09938f62de69402452b66275215250445348 (patch)
tree3104fd758d6d5cf6644a2fd99ae0344459f62510 /main/shorewall-core
parentfb48ae07d8fe4a462244eeb522a39ca2690bb114 (diff)
downloadaports-681f09938f62de69402452b66275215250445348.tar.bz2
aports-681f09938f62de69402452b66275215250445348.tar.xz
main/shorewall-core: upgrade to 4.6.3.1
Diffstat (limited to 'main/shorewall-core')
-rw-r--r--main/shorewall-core/APKBUILD19
-rw-r--r--main/shorewall-core/shorewallrc.alpine23
2 files changed, 35 insertions, 7 deletions
diff --git a/main/shorewall-core/APKBUILD b/main/shorewall-core/APKBUILD
index 39477db1e7..f8f0886154 100644
--- a/main/shorewall-core/APKBUILD
+++ b/main/shorewall-core/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-core
-pkgver=4.6.2.1
+pkgver=4.6.3.1
_ver=$pkgver
case $pkgver in
@@ -10,7 +10,7 @@ esac
pkgrel=0
pkgdesc="Core libraries for Shorewall"
url="http://www.shorewall.net/"
-arch=""
+arch="noarch"
license="GPL-2"
depends=""
# coreutils for install -T
@@ -18,6 +18,7 @@ makedepends="coreutils bash"
replaces=""
subpackages=""
source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/shorewall-core-$pkgver.tar.bz2
+ shorewallrc.alpine
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -29,18 +30,22 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ cp "$srcdir"/shorewallrc.alpine .
}
build() {
cd "$_builddir"
- ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+ ./configure || return 1
}
package() {
cd "$_builddir"
- DESTDIR="$pkgdir" ./install.sh || return 1
+ DESTDIR="$pkgdir" ./install.sh shorewallrc.alpine || return 1
}
-md5sums="26cde22b585f08a8a9dc5f0d02012ba0 shorewall-core-4.6.2.1.tar.bz2"
-sha256sums="836c7930d103926838af68dae31e0725180b5e8de46190b313c8207a28dbcae9 shorewall-core-4.6.2.1.tar.bz2"
-sha512sums="b17e13354f7af3c69a9c001c4ba22dbf3b11589e29d513f7f0c2f74913a4f889b9463a2f29976b6c41903e0f820763adc9ca2a7fcf31005bb618d64589826739 shorewall-core-4.6.2.1.tar.bz2"
+md5sums="6bc3bf44b1d6f1a6615b7052968324f3 shorewall-core-4.6.3.1.tar.bz2
+422c5d36fcee177acba58756b0fec7e2 shorewallrc.alpine"
+sha256sums="abec8495d0631f294f271cd3a1b108c52b94b3deeee9297a6b485a4ec4872702 shorewall-core-4.6.3.1.tar.bz2
+99f588523594b5a8062b2f43ab9f59daf91f12634b178f30dd7cb61786bd8220 shorewallrc.alpine"
+sha512sums="1bc9b1be741fabe6b4df3bf57e1447a7b6a81c070ddcda2eb8978e04799e551887e7ff05fdbe3c13ed7b8968b6629ba2b0152d7f58e71951a3ea1e4c3bc5200e shorewall-core-4.6.3.1.tar.bz2
+c076ae42e7b404cecf521fdc32f92ba3a6b77d61579726abde2f00b6b6282e55b0b334b9fe5e43a6e4ae56361cce3214d9a38099f9f8714f03ae4fb888c744b7 shorewallrc.alpine"
diff --git a/main/shorewall-core/shorewallrc.alpine b/main/shorewall-core/shorewallrc.alpine
new file mode 100644
index 0000000000..fd0314f478
--- /dev/null
+++ b/main/shorewall-core/shorewallrc.alpine
@@ -0,0 +1,23 @@
+#
+# Default Shorewall 4.5 rc file
+#
+HOST=linux #Generic Linux
+BUILD=linux #Default is to detect the build system
+PREFIX=/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=/etc #Directory where subsystem configurations are installed
+SBINDIR=/usr/sbin #Directory where system administration programs are installed
+MANDIR=${SHAREDIR}/man #Directory where manpages are installed.
+INITDIR= #Directory where SysV init scripts are installed.
+INITFILE= #Name of the product's installed SysV init script
+INITSOURCE= #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD= #Directory where .service files are installed (systems running systemd only)
+SERVICEFILE= #Name of the file to install in $SYSTEMD. Default is $PRODUCT.service
+SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR= #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/$PRODUCT #Directory where product variable data is stored.