aboutsummaryrefslogtreecommitdiffstats
path: root/main/sysklogd
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-17 23:54:46 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:50 +0000
commit840cbc855a8a806ac20043c9989abbe8558ec897 (patch)
treedb72668c82223579e716a103c19f68aaa864024c /main/sysklogd
parent17de266deecff9ce55f82ae0ef136fc575c862af (diff)
downloadaports-840cbc855a8a806ac20043c9989abbe8558ec897.tar.bz2
aports-840cbc855a8a806ac20043c9989abbe8558ec897.tar.xz
main/sysklogd: do not use test suite that forces OOPS on purpose
Diffstat (limited to 'main/sysklogd')
-rw-r--r--main/sysklogd/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/sysklogd/APKBUILD b/main/sysklogd/APKBUILD
index 8472266e58..adf2f73ecf 100644
--- a/main/sysklogd/APKBUILD
+++ b/main/sysklogd/APKBUILD
@@ -9,6 +9,7 @@ license="GPL BSD"
subpackages="$pkgname-doc"
depends=""
makedepends="linux-headers"
+options="!check" # requires kernel sources to build oops.ko
source="http://www.infodrom.org/projects/$pkgname/download/$pkgname-$pkgver.tar.gz
sysklogd.logrotate
sysklogd.daily
@@ -25,12 +26,12 @@ source="http://www.infodrom.org/projects/$pkgname/download/$pkgname-$pkgver.tar.
builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd $builddir
+ cd "$builddir"
make CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
}
package() {
- cd $builddir
+ cd "$builddir"
make INSTALL="install -D" prefix="$pkgdir" install
install -D -m644 "$srcdir"/sysklogd.logrotate \