aboutsummaryrefslogtreecommitdiffstats
path: root/main/the_silver_searcher
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-04 10:20:58 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-09-05 06:21:51 +0000
commit074f57910ac16e62758df90fbd414eecd1d84dcf (patch)
treef05468a08be1ef3d20dc2db914ac5f4efaf4e5f2 /main/the_silver_searcher
parentb6cfe9769fca305c3231af8f8242e5d737c0c743 (diff)
downloadaports-074f57910ac16e62758df90fbd414eecd1d84dcf.tar.bz2
aports-074f57910ac16e62758df90fbd414eecd1d84dcf.tar.xz
main/the_silver_searcher: upgrade to 2.1.0
Diffstat (limited to 'main/the_silver_searcher')
-rw-r--r--main/the_silver_searcher/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/main/the_silver_searcher/APKBUILD b/main/the_silver_searcher/APKBUILD
index 3dd0352151..ade0cfef4f 100644
--- a/main/the_silver_searcher/APKBUILD
+++ b/main/the_silver_searcher/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=the_silver_searcher
-pkgver=2.0.0
-pkgrel=1
+pkgver=2.1.0
+pkgrel=0
pkgdesc="A code searching tool similar to ack, with a focus on speed."
-url="http://geoff.greer.fm/ag/"
+url="https://geoff.greer.fm/ag/"
arch="all"
license="ASL 2.0"
depends=""
@@ -12,9 +12,9 @@ makedepends="pcre-dev xz-dev zlib-dev"
subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="http://geoff.greer.fm/ag/releases/$pkgname-$pkgver.tar.gz"
+source="https://geoff.greer.fm/ag/releases/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build () {
cd "$builddir"
./configure \
@@ -23,14 +23,13 @@ build () {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
bashcomp() {
@@ -40,7 +39,7 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
mv "$pkgdir"/usr/share/the_silver_searcher/completions/ag.bashcomp.sh \
- "$subpkgdir"/usr/share/bash-completion/completions/ag || return 1
+ "$subpkgdir"/usr/share/bash-completion/completions/ag
rmdir -p "$pkgdir"/usr/share/the_silver_searcher/completions/ 2>&1 || true
}
@@ -52,9 +51,9 @@ zshcomp() {
mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
mv "$pkgdir"/usr/share/zsh/site-functions/_the_silver_searcher \
- "$subpkgdir"/usr/share/zsh/site-functions/ || return 1
+ "$subpkgdir"/usr/share/zsh/site-functions/
rmdir -p "$pkgdir"/usr/share/zsh/site-functions/ 2>&1 || true
}
-sha512sums="54d6a47e375d5f978d7fc47a0854ea0691789e33307f6bef18711fae94d1c9a1127f8f8e6d27fb5d4a1b70f05ca6892a21cff42a72cfac788e421640631274b4 the_silver_searcher-2.0.0.tar.gz"
+sha512sums="27cf5c0990551261833aed0232438da6ec079d619a8dcd15fcf866a3997237435c2ba8dec88bb8b6abb8ef2f3498145903c3b0f39274b2660680c22fed65dd62 the_silver_searcher-2.1.0.tar.gz"