aboutsummaryrefslogtreecommitdiffstats
path: root/main/the_silver_searcher
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-13 17:15:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-13 19:22:37 +0000
commitae3c2f169d1a8c986318f306de8e5b20e01033a9 (patch)
tree163b9449f02d13731bfa3335e219d8a610e9841b /main/the_silver_searcher
parent40d074c249ab8664d462b112900a0d37c9487a28 (diff)
downloadaports-ae3c2f169d1a8c986318f306de8e5b20e01033a9.tar.bz2
aports-ae3c2f169d1a8c986318f306de8e5b20e01033a9.tar.xz
main/the_silver_searcher: fix build and add check
trick configurescript to not find fopencookie to fix build. Also add a simple test as upstream doesn't provide tests.
Diffstat (limited to 'main/the_silver_searcher')
-rw-r--r--main/the_silver_searcher/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/the_silver_searcher/APKBUILD b/main/the_silver_searcher/APKBUILD
index ade0cfef4f..a69e6e039c 100644
--- a/main/the_silver_searcher/APKBUILD
+++ b/main/the_silver_searcher/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=the_silver_searcher
pkgver=2.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A code searching tool similar to ack, with a focus on speed."
url="https://geoff.greer.fm/ag/"
arch="all"
@@ -17,6 +17,7 @@ source="https://geoff.greer.fm/ag/releases/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build () {
cd "$builddir"
+ ac_cv_func_fopencookie=no \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,6 +28,11 @@ build () {
make
}
+check() {
+ cd "$builddir"
+ ./ag --help > /dev/null
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install