aboutsummaryrefslogtreecommitdiffstats
path: root/main/wine/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-16 12:57:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-16 12:57:23 +0000
commit00d8a7996324d05f7c3bda266691f68c4cfd587f (patch)
tree1fb774c504038075d923bc456c755f7b22978d53 /main/wine/APKBUILD
parent92f0c4a8fb6a46befb00de60325acfd5efffd771 (diff)
downloadaports-00d8a7996324d05f7c3bda266691f68c4cfd587f.tar.bz2
aports-00d8a7996324d05f7c3bda266691f68c4cfd587f.tar.xz
main/wine: build fixes for bison-3
Diffstat (limited to 'main/wine/APKBUILD')
-rw-r--r--main/wine/APKBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
index 665fcd9cc9..d456ef3287 100644
--- a/main/wine/APKBUILD
+++ b/main/wine/APKBUILD
@@ -2,7 +2,7 @@
pkgname=wine
pkgver=1.6
_ver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
arch="x86"
@@ -17,6 +17,11 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
tiff-dev v4l-utils-dev udisks2-dev
autoconf automake"
source="http://downloads.sourceforge.net/project/wine/Source/wine-$_ver.tar.bz2
+ jscript-use-bison-directives-instead-of-defines.patch
+ msi-use-bison-directives-insetad-of-defines.patch
+ vbscript-Use-bison-directives-instead-of-defines.patch
+ wbemprox-Use-bison-directives-instead-of-defines.patch
+ wrc-Remove-non-bison-compatibility-code.patch
"
_builddir="$srcdir"/$pkgname-$_ver
@@ -42,7 +47,7 @@ build() {
--with-dbus \
--with-x \
|| return 1
- make
+ make
}
package() {
@@ -53,6 +58,21 @@ package() {
"$pkgdir"/usr/bin/wine
}
-md5sums="47cf1e121d395e9c8ca1a4ab88f1e658 wine-1.6.tar.bz2"
-sha256sums="e1f130efbdcbfa211ca56ee03357ccd17a31443889b4feebdcb88248520b42ae wine-1.6.tar.bz2"
-sha512sums="f8a98d732547c685e20ec3b7c50b44943307396b93097ef53b01ab1919209a159b81bd1560d8b2f242cec7f7303e446a8632ddd238359fc1861acc555105c92a wine-1.6.tar.bz2"
+md5sums="47cf1e121d395e9c8ca1a4ab88f1e658 wine-1.6.tar.bz2
+38bea0015354da182dfa7f7ff870cbbb jscript-use-bison-directives-instead-of-defines.patch
+7fd584ab875b0834ee457eeb351b1190 msi-use-bison-directives-insetad-of-defines.patch
+40fc099154043424223bcf5836a64aa0 vbscript-Use-bison-directives-instead-of-defines.patch
+cd1fd88a4f58db703828eb5ec0e5c45f wbemprox-Use-bison-directives-instead-of-defines.patch
+c889b79461ee7a7480f8cc89682cee76 wrc-Remove-non-bison-compatibility-code.patch"
+sha256sums="e1f130efbdcbfa211ca56ee03357ccd17a31443889b4feebdcb88248520b42ae wine-1.6.tar.bz2
+80d16a130e9e84a0eb7853f36bb05dfaf420ec78e1f8df563d7ed4694a10df7a jscript-use-bison-directives-instead-of-defines.patch
+b84ca975dba80f0cb90321177f2bcbac35f86d244fa15e7ae3de921ddb10803c msi-use-bison-directives-insetad-of-defines.patch
+e8e20f6ca8702dbe76fbe12751685d1ae28157fb430fe3280098201aaa96769c vbscript-Use-bison-directives-instead-of-defines.patch
+3da101c81ae94d14dbcda8d0af32ab4dcdda85a020c01640a75581a011d9f4dc wbemprox-Use-bison-directives-instead-of-defines.patch
+5348fde97aa89825a872805d84062dc623782a7b7d8321f6b3ddb4ff2dd11f8f wrc-Remove-non-bison-compatibility-code.patch"
+sha512sums="f8a98d732547c685e20ec3b7c50b44943307396b93097ef53b01ab1919209a159b81bd1560d8b2f242cec7f7303e446a8632ddd238359fc1861acc555105c92a wine-1.6.tar.bz2
+5ef7ec422aa13ea9b26937eed8ee63ed12452d2c7dbc8ae9ec3f336dbf3e5be72845d19dcaeac5598303c09833896accd200bb0cca48dadef9e4a748ce5ef60d jscript-use-bison-directives-instead-of-defines.patch
+23863f79c90614430a0ba880daaad76c95d7d0bbe2d192a02b0121012f39f68d46cfb86fb01990ca19c358807f16e383d891ca295057774901277ba3f5236392 msi-use-bison-directives-insetad-of-defines.patch
+90ed0ec93372d3c45bacce3e90c825205eeb31645848a48875f71ff066e59b53f1a97f575615e66d1f2fff82703c60e016969d5b2fa66bc7f23688b67d2cf3e7 vbscript-Use-bison-directives-instead-of-defines.patch
+5631449ede0f8f93f9a02c52bcf8e583c6ca2216113c911b6f6ed145b22eab09b9756df4dbb68a449ecbc4e7ac88d87311789f1dddf495a771c96345bf032c18 wbemprox-Use-bison-directives-instead-of-defines.patch
+b34670680b5f0bef33e49ae411b2728e18d84a35fbb73f853b1692e88585b28d30c0f49f9bc53fbd9e440fc9b178e9b52e51434d4c13b977815dc982a3c72cec wrc-Remove-non-bison-compatibility-code.patch"