aboutsummaryrefslogtreecommitdiffstats
path: root/main/x265
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-10-06 13:34:34 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-10-06 13:36:18 +0200
commit42496b36c09eb5b726d27f90b73037aa3ba20374 (patch)
tree88f238071a7344e9d884cfede68f2140f332f8db /main/x265
parent104f2030804464d0ca8dc8d0602697b7ae2c5899 (diff)
downloadaports-42496b36c09eb5b726d27f90b73037aa3ba20374.tar.bz2
aports-42496b36c09eb5b726d27f90b73037aa3ba20374.tar.xz
main/x265: new aport
Diffstat (limited to 'main/x265')
-rw-r--r--main/x265/APKBUILD46
-rw-r--r--main/x265/x265-1.7-fix-slowness-with-gcc-5.1.patch28
2 files changed, 74 insertions, 0 deletions
diff --git a/main/x265/APKBUILD b/main/x265/APKBUILD
new file mode 100644
index 0000000000..d4a574c350
--- /dev/null
+++ b/main/x265/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=x265
+pkgver=1.7
+pkgrel=0
+pkgdesc="Open Source H265/HEVC video encoder"
+url="https://bitbucket.org/multicoreware/x265"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev yasm cmake"
+install=""
+subpackages="$pkgname-dev"
+source="http://ftp.videolan.org/pub/videolan/x265/x265_${pkgver}.tar.gz
+ x265-1.7-fix-slowness-with-gcc-5.1.patch"
+
+_builddir="$srcdir/x265_$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"/build/linux
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr ../../source
+}
+
+package() {
+ cd "$_builddir"/build/linux
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="ff31a807ebc868aa59b60706e303102f x265_1.7.tar.gz
+30c7fc491f22cbdec1ee17caab7d620a x265-1.7-fix-slowness-with-gcc-5.1.patch"
+sha256sums="a52ca95e8e64219c1e8e73a9abf0bb7151ced2c93756a623cf2b7e5cf8226585 x265_1.7.tar.gz
+1414e10c96654070cf0e96dcb79c560fc415e48250cd5bd0ad8a2a6d7f754d50 x265-1.7-fix-slowness-with-gcc-5.1.patch"
+sha512sums="cf6fce24b008d36bbc79e2488ab5fb3010aa588113645597ffc66959088a73b3ba72f6bb81bd16e36847a73b50b8f264cff0899162552418ae499170c286eb89 x265_1.7.tar.gz
+5d0807ade416c15156252b27e9b6fca10743274ec3b1e8e638299604b3a12f437e54aa5864c179c9f2b976011d67a7ab648252ade01d7d7298d9c4097eba3c4d x265-1.7-fix-slowness-with-gcc-5.1.patch"
diff --git a/main/x265/x265-1.7-fix-slowness-with-gcc-5.1.patch b/main/x265/x265-1.7-fix-slowness-with-gcc-5.1.patch
new file mode 100644
index 0000000000..6aa679dbc1
--- /dev/null
+++ b/main/x265/x265-1.7-fix-slowness-with-gcc-5.1.patch
@@ -0,0 +1,28 @@
+# HG changeset patch
+# User Deepthi Nandakumar <deepthi@multicorewareinc.com>
+# Date 1434559454 -19800
+# Wed Jun 17 22:14:14 2015 +0530
+# Branch stable
+# Node ID 98325f22a1bad500e6a0c3372bf8177e81167cae
+# Parent e0738af788da598a3cdf4458dbb46fbb07563534
+fix issue #143 x265 is slow when it is build with GCC 5.1
+
+diff -r e0738af788da -r 98325f22a1ba source/common/vec/vec-primitives.cpp
+--- a/source/common/vec/vec-primitives.cpp Wed May 20 10:29:09 2015 -0500
++++ b/source/common/vec/vec-primitives.cpp Wed Jun 17 22:14:14 2015 +0530
+@@ -32,12 +32,13 @@
+ #define HAVE_SSE4
+ #define HAVE_AVX2
+ #elif defined(__GNUC__)
+-#if __clang__ || (__GNUC__ >= 4 && __GNUC_MINOR__ >= 3)
++#define GCC_VERSION (__GNUC__ * 10000 + __GNUC_MINOR__ * 100 + __GNUC_PATCHLEVEL__)
++#if __clang__ || GCC_VERSION >= 40300 /* gcc_version >= gcc-4.3.0 */
+ #define HAVE_SSE3
+ #define HAVE_SSSE3
+ #define HAVE_SSE4
+ #endif
+-#if __clang__ || (__GNUC__ >= 4 && __GNUC_MINOR__ >= 7)
++#if __clang__ || GCC_VERSION >= 40700 /* gcc_version >= gcc-4.7.0 */
+ #define HAVE_AVX2
+ #endif
+ #elif defined(_MSC_VER)