aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2018-06-01 05:39:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-07 07:37:34 +0000
commit1bdd30d22d011e2c72ef411c0b976a7df6fc789f (patch)
tree777b40669ee027771e17a72f7a4d31dfb4ba7b3f /main
parenta13801c1cfca4ace11085fb1289388bff93d213b (diff)
downloadaports-1bdd30d22d011e2c72ef411c0b976a7df6fc789f.tar.bz2
aports-1bdd30d22d011e2c72ef411c0b976a7df6fc789f.tar.xz
main/llvm5: test failures are gone in new s390x builder
Diffstat (limited to 'main')
-rw-r--r--main/llvm5/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/llvm5/APKBUILD b/main/llvm5/APKBUILD
index 261319c48d..24bf82a342 100644
--- a/main/llvm5/APKBUILD
+++ b/main/llvm5/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=llvm
pkgver=5.0.1
_majorver=${pkgver%%.*}
pkgname=$_pkgname$_majorver
-pkgrel=3
+pkgrel=4
pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
arch="all"
url="http://llvm.org/"
@@ -124,12 +124,7 @@ build() {
check() {
cd "$builddir"/build
- # XXX: Few tests fail on s390x, ignore it for now. See build log
- # https://gist.github.com/jirutka/6edc951ad5b8002cf1780546cf661edc
- case "$CARCH" in
- s390x) make check-llvm || true;;
- *) make check-llvm;;
- esac
+ make check-llvm
}
package() {