aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-01-23 19:36:39 -0500
committerTimo Teräs <timo.teras@iki.fi>2018-02-01 20:26:28 +0000
commit3bc89bffe7ffa8710beefc212ba4d61acc78f73a (patch)
tree0e68328274a9dbbe0286373f7348d4cf54f0f382 /main
parent27e6670beec66c6d903ac15c6be985b58deb7ecd (diff)
downloadaports-3bc89bffe7ffa8710beefc212ba4d61acc78f73a.tar.bz2
aports-3bc89bffe7ffa8710beefc212ba4d61acc78f73a.tar.xz
main/gdb: enable gdbserver
It compiles with musl now.
Diffstat (limited to 'main')
-rw-r--r--main/gdb/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index f11541547c..62ba1ddbc5 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
pkgver=8.0.1
-pkgrel=4
+pkgrel=5
pkgdesc="The GNU Debugger"
url="https://www.sourceware.org/gdb/"
arch="all"
@@ -37,11 +37,8 @@ build () {
# use system zlib if not cross compiling
[ "$CBUILD" = "$CHOST" ] && _config="$_config --with-system-zlib"
- # gdb server does not compile with musl
- [ "$CTARGET_LIBC" = musl ] && _config="$_config --disable-gdbserver"
-
- # avoid generation of mangled and non-mangled objects on ppc64
- [ "$CARCH" = ppc64le ] && _config="$_config --enable-build-with-cxx=no"
+ # avoid generation of mangled and non-mangled objects on ppc64
+ [ "$CARCH" = ppc64le ] && _config="$_config --enable-build-with-cxx=no"
./configure $_config || return 1
(cd opcodes && ./configure $_config) || return 1