aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-15 10:31:15 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-15 10:34:39 +0200
commit78c96412d1906089b706dcca9c0827ec5d232bb8 (patch)
tree96da1c2d37390380e7df78c77ae005b5f122d5d1 /main
parent9a510012ea710e6b1d7481fab74de7bafeaf1955 (diff)
downloadaports-78c96412d1906089b706dcca9c0827ec5d232bb8.tar.bz2
aports-78c96412d1906089b706dcca9c0827ec5d232bb8.tar.xz
main/zip: fetch tarballs from sourceforge
The info-zip ftp servers seems unreliable. Fetching the tarballs from sourceforge has the additional advantages that they support HTTPS. Other distributions such as Arch Linux also fetch the tarball from source forge. Does not include a pkgrel bump since the source files and therefore the resulting binaries should be identical.
Diffstat (limited to 'main')
-rw-r--r--main/zip/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/zip/APKBUILD b/main/zip/APKBUILD
index ad4319a03a..5dd888d760 100644
--- a/main/zip/APKBUILD
+++ b/main/zip/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=zip
pkgver=3.0
+_pkgver=${pkgver%.*}${pkgver##*.}
pkgrel=7
pkgdesc="Creates PKZIP-compatible .zip files"
url="http://www.info-zip.org/pub/infozip/Zip.html"
@@ -10,12 +11,12 @@ license="Info-ZIP"
depends="unzip" #unzip is needed for `zip -T`
makedepends=""
subpackages="$pkgname-doc"
-source="ftp://ftp.info-${pkgname}.org/pub/info${pkgname}/src/${pkgname}30.zip
+source="https://downloads.sourceforge.net/infozip/${pkgname}${_pkgver}.tar.gz
10-zip-3.0-build.patch
20-zip-3.0-exec-stack.patch
30-zip-3.0-pic.patch"
-builddir="$srcdir"/${pkgname}30
+builddir="$srcdir"/${pkgname}${_pkgver}
build() {
cd "$builddir"
@@ -28,7 +29,7 @@ package() {
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="642ea6768d79adc1499251a3fb7bfc7ddc8d708699cbf9e0cfe849deda94165cb93e21dc2606bea1166ae5d8531e1e2cb056a7246bf2ab86ea7587bd4712d8d8 zip30.zip
+sha512sums="c1c3d62bf1426476c0f9919b568013d6d7b03514912035f09ee283226d94c978791ad2af5310021e96c4c2bf320bfc9d0b8f4045c48e4667e034d98197e1a9b3 zip30.tar.gz
e71f7c6f6dd6f8f576018581b155f324eaf6810a2f7c5c402843bdfc3ce6772f09be166b33ff34dcb703774694b18584c8de1763f29895c1d563661679f43d71 10-zip-3.0-build.patch
2a6824066543684e02731bd36930e0ffa6ab48162c61d5e7af08e8ea0795401271ef28bdd0f6ace865d91fdb1a05b643813cdd458a9fdf554f1ca298ea7f50e3 20-zip-3.0-exec-stack.patch
fcb2d728d79160128064af90eb17a9c03e980d9619c4d930c4dbf79cb13842c7bb694036dcbf5cd9b412efc6fc0b86bb94a88b3f110b6b63bf6bda2b97fe0568 30-zip-3.0-pic.patch"