aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-06 09:42:10 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-06 09:42:10 +0000
commit82a605c20eecceb9d849109b2d6d7d13b0c07532 (patch)
treefbd9037e0c03946cbdf8b93693a0a4cd390e0d4d /main
parent6e27581ae4ce350d80feb8a6961298757d7637ea (diff)
downloadaports-82a605c20eecceb9d849109b2d6d7d13b0c07532.tar.bz2
aports-82a605c20eecceb9d849109b2d6d7d13b0c07532.tar.xz
main/libtool: fix building with slibtool
Diffstat (limited to 'main')
-rw-r--r--main/libtool/APKBUILD15
-rw-r--r--main/libtool/libtool-no-undefined.patch30
2 files changed, 36 insertions, 9 deletions
diff --git a/main/libtool/APKBUILD b/main/libtool/APKBUILD
index de86f2aeb7..5e998f67d5 100644
--- a/main/libtool/APKBUILD
+++ b/main/libtool/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtool
pkgver=2.4.6
-pkgrel=1
+pkgrel=2
pkgdesc="A generic library support script"
arch="all"
license='GPL'
url="http://www.gnu.org/software/libtool"
source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz
libtool-fix-cross-compile.patch
+ libtool-no-undefined.patch
"
depends="bash libltdl"
makedepends="m4 help2man"
@@ -22,9 +23,8 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-static \
- || return 1
- make
+ --disable-static
+ make V=1
}
package() {
@@ -39,9 +39,6 @@ libltdl() {
mv "$pkgdir/usr/lib/libltdl.so"* "$subpkgdir/usr/lib/"
}
-md5sums="addf44b646ddb4e3919805aa88fa7c5e libtool-2.4.6.tar.gz
-3657a65e226879586c29360eac6ae41b libtool-fix-cross-compile.patch"
-sha256sums="e3bd4d5d3d025a36c21dd6af7ea818a2afcd4dfc1ea5a17b39d7854bcd0c06e3 libtool-2.4.6.tar.gz
-c98362e9b1efd90618813a6901144452dc03f51e6300686bb07e068ac851c245 libtool-fix-cross-compile.patch"
sha512sums="3233d81cb2739a54b840a0a82064eebbfaa4fb442fb993a35d6bd41d8395c51f038c90ae048b9252f172d0a5bbfb4b36e2b13d4477001f9ff7d4124237819a18 libtool-2.4.6.tar.gz
-aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch"
+aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch
+5dc4ca593a8d379de347e58ee32f5190880494e1a4efb61cac6e7a5ef9e477c2dc6655e15320066a8e441b3efaf8c0af1776fe430e6d33c38c2b74893f0d646b libtool-no-undefined.patch"
diff --git a/main/libtool/libtool-no-undefined.patch b/main/libtool/libtool-no-undefined.patch
new file mode 100644
index 0000000000..fcf33192ad
--- /dev/null
+++ b/main/libtool/libtool-no-undefined.patch
@@ -0,0 +1,30 @@
+--- libtool-2.4.6.orig/libltdl/Makefile.am
++++ libtool-2.4.6/libltdl/Makefile.am
+@@ -47,7 +47,6 @@
+ AM_CPPFLAGS += -DLT_CONFIG_H='<$(LT_CONFIG_H)>' \
+ -DLTDL -I. -I$(srcdir) -Ilibltdl \
+ -I$(srcdir)/libltdl
+-AM_LDFLAGS += -no-undefined
+ LTDL_VERSION_INFO = -version-info 10:1:3
+
+ noinst_LTLIBRARIES += $(LT_DLLOADERS)
+--- libtool-2.4.6.orig/libltdl/Makefile.in
++++ libtool-2.4.6/libltdl/Makefile.in
+@@ -441,7 +441,6 @@
+ # (not as a sub-package!) using 'nostdinc':
+ AM_CPPFLAGS = -DLT_CONFIG_H='<$(LT_CONFIG_H)>' -DLTDL -I. -I$(srcdir) \
+ -Ilibltdl -I$(srcdir)/libltdl
+-AM_LDFLAGS = -no-undefined
+ BUILT_SOURCES = libltdl/$(LT_ARGZ_H)
+ include_HEADERS = $(am__append_1)
+ noinst_LTLIBRARIES = $(LT_DLLOADERS) $(am__append_3)
+--- libtool-2.4.6.orig/Makefile.in
++++ libtool-2.4.6/Makefile.in
+@@ -593,7 +593,6 @@
+ AM_CPPFLAGS = -DLT_CONFIG_H='<$(LT_CONFIG_H)>' -DLTDL -I. -I$(srcdir) \
+ -Ilibltdl -I$(srcdir)/libltdl -Ilibltdl/libltdl \
+ -I$(srcdir)/libltdl/libltdl
+-AM_LDFLAGS = -no-undefined
+ SUBDIRS = .
+ DIST_SUBDIRS = $(SUBDIRS)
+ EXTRA_DIST = bootstrap bootstrap.conf $(build_scripts) cfg.mk maint.mk \