aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-19 14:53:07 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-19 14:53:07 +0200
commitaf056961cdbc595955629297cc1e0efbdcd8c2ff (patch)
tree2bad0e8acf81a1e58a30b962262f25e39ac285ea /main
parentceef2c4c424d367d983eac296550a1e7bdc56453 (diff)
downloadaports-af056961cdbc595955629297cc1e0efbdcd8c2ff.tar.bz2
aports-af056961cdbc595955629297cc1e0efbdcd8c2ff.tar.xz
main/alpine-conf: fix xfs support for /boot
Diffstat (limited to 'main')
-rw-r--r--main/alpine-conf/0001-setup-disk-add-xfs-support-as-boot_fs.patch34
-rw-r--r--main/alpine-conf/APKBUILD6
2 files changed, 38 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-setup-disk-add-xfs-support-as-boot_fs.patch b/main/alpine-conf/0001-setup-disk-add-xfs-support-as-boot_fs.patch
new file mode 100644
index 0000000000..f754af797a
--- /dev/null
+++ b/main/alpine-conf/0001-setup-disk-add-xfs-support-as-boot_fs.patch
@@ -0,0 +1,34 @@
+From c15da3bf6ba6d7b05cac6c6182efdd4149554b82 Mon Sep 17 00:00:00 2001
+From: Jakub Skrzypnik <j.skrzypnik@openmailbox.orxg>
+Date: Fri, 6 Jan 2017 08:47:02 +0100
+Subject: [PATCH] setup-disk: add xfs support as boot_fs
+
+---
+ setup-disk.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup-disk.in b/setup-disk.in
+index 023974e..c4103e4 100644
+--- a/setup-disk.in
++++ b/setup-disk.in
+@@ -141,7 +141,7 @@ find_mount_dev() {
+ }
+
+ supported_boot_fs() {
+- local supported="ext2 ext3 ext4 btrfs"
++ local supported="ext2 ext3 ext4 btrfs xfs"
+ local fs=
+ for fs in $supported; do
+ [ "$fs" = "$1" ] && return 0
+@@ -941,7 +941,7 @@ usage() {
+ If BOOTFS, ROOTFS, VARFS are specified, then format a partition with specified
+ filesystem. If not specified, the default filesystem is ext4.
+ Supported filesystems for
+- boot: ext2, ext3, ext4, btrfs
++ boot: ext2, ext3, ext4, btrfs, xfs
+ root: ext2, ext3, ext4, btrfs, xfs
+ var: ext2, ext3, ext4, btrfs, xfs
+ __EOF__
+--
+2.13.0
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 619f95e2bb..640eb4c359 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=3.6.0_rc1
-pkgrel=1
+pkgrel=2
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
arch="all"
@@ -9,6 +9,7 @@ license="MIT"
depends="openrc>0.13 busybox>=1.26.1-r3"
source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz
0001-setup-keymap-allow-specify-the-variant-together-with.patch
+ 0001-setup-disk-add-xfs-support-as-boot_fs.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -26,4 +27,5 @@ package() {
}
sha512sums="3d1b7c18a406791948485cd871942b94a0f2eadd6f1f0e9c87f92fb15750b9b41ffec0d7d2d16361a1e25f029765005e72b266ce48609ea0b7c5e5c99606d04f alpine-conf-3.6.0_rc1.tar.xz
-67a1d72e45ba74d710a841c0a2671f74f792f6649fb530f86763fe2f10fc0005c644dfdcec25b00bc5eb0b97b2418775e95202269ef3b3f56b6c22044630fb86 0001-setup-keymap-allow-specify-the-variant-together-with.patch"
+67a1d72e45ba74d710a841c0a2671f74f792f6649fb530f86763fe2f10fc0005c644dfdcec25b00bc5eb0b97b2418775e95202269ef3b3f56b6c22044630fb86 0001-setup-keymap-allow-specify-the-variant-together-with.patch
+fee1cb10a077ea7b5c01dc6367bc929d6c2eecf257848263435b5c9c130f6fb552f39809ea6403232d2f8ecea4b14b29a725a694228878ee0b1bb7ead696071b 0001-setup-disk-add-xfs-support-as-boot_fs.patch"