aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-13 06:47:13 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-13 06:47:13 +0000
commitcdaf9d0f0023f73cadcb09fea8daefe8ca82392d (patch)
treea147d0000bfcd21bd3bfd6276a02d7af82bad889 /main
parenta3cd9441072d774449b3fb918a3b5fe5489a7466 (diff)
downloadaports-cdaf9d0f0023f73cadcb09fea8daefe8ca82392d.tar.bz2
aports-cdaf9d0f0023f73cadcb09fea8daefe8ca82392d.tar.xz
main/speedtest-cli: upgrade to 1.0.4, modernize APKBUILD
Diffstat (limited to 'main')
-rw-r--r--main/speedtest-cli/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/main/speedtest-cli/APKBUILD b/main/speedtest-cli/APKBUILD
index abc5243681..423101af6f 100644
--- a/main/speedtest-cli/APKBUILD
+++ b/main/speedtest-cli/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=speedtest-cli
-pkgver=1.0.3
+pkgver=1.0.4
pkgrel=0
pkgdesc="Command line interface for testing internet bandwidth using speedtest.net"
url="https://github.com/sivel/speedtest-cli"
@@ -9,20 +9,23 @@ arch="noarch"
license="ASL 2.0"
depends="python3"
makedepends="python3-dev"
-install=""
-subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/sivel/speedtest-cli/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
install -Dm755 speedtest.py "$pkgdir"/usr/bin/speedtest-cli
}
-sha512sums="0a8527e5dc60ca55c199619707c344b6e4e44702a5283c183c3c057776464933bf039ee3a3928c1a48c2d2675d0186b89f25670b1ef17ea237e98b7d813f8f1e speedtest-cli-1.0.3.tar.gz"
+sha512sums="30499e81b799c05400c7e2c5b15ec3191dbf09becaa93f68c5022773fd011f954129298dc226d2317c55b4f1077229f59dc05dff572fcb1d05c05f15af9a67b4 speedtest-cli-1.0.4.tar.gz"