aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-02 12:13:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-07 11:44:31 +0000
commitd44b85c310a88bf08a996dd2159dd335c0e468b9 (patch)
tree1abe1fe2d25754ef942f27422c06b567aa8cba69 /main
parent29eea5b912889bee4c52d1b721ae352839d87a35 (diff)
downloadaports-d44b85c310a88bf08a996dd2159dd335c0e468b9.tar.bz2
aports-d44b85c310a88bf08a996dd2159dd335c0e468b9.tar.xz
main/aports-build: fix dependencies for releases, remove irc
- remove every reference to irc. all messages should go via mqtt - fix dependencies for releases. this is so we dont need have things like mkinitfs installed at all times on builders - set server status to failed if build fails
Diffstat (limited to 'main')
-rw-r--r--main/aports-build/APKBUILD4
-rw-r--r--main/aports-build/aports-build14
2 files changed, 5 insertions, 13 deletions
diff --git a/main/aports-build/APKBUILD b/main/aports-build/APKBUILD
index 993ab5a7c6..eba0a75e42 100644
--- a/main/aports-build/APKBUILD
+++ b/main/aports-build/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aports-build
-pkgver=1.2
+pkgver=1.3
pkgrel=0
pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux"
url="http://alpinelinux.org"
@@ -40,7 +40,7 @@ package() {
"$pkgdir"/etc/buildrepo/plugins.d/report-build-errors.lua
}
-sha512sums="e5fc3d6993f387a21aa73c9c0dc7caefad8f8420fb62044566cd0cb02ca7a65d2b69e8213e97b5d6dc035fca0e7d31a4c5d3134d066fe1a27bb166cd6e8a1f53 aports-build
+sha512sums="60d33befbea0745bd18c8373e2b02be23d120503d813237972eca1122e45a84a9e1afbde6c1a40424485b8c9630c27be0948966757ba40c8e8285673bbb7e843 aports-build
821035bda47152c341ec94bf960fa67e3377051826712ceb74f39103e6e422777b6e082231bfb87865653d2b93b7d3154cfc24abf65a52e3e66da69412dd7e41 aports-build.initd
62ed5cb6d1fef03fa707512c8c99c572a91e64706ebcc2e7097108811818615618bab908292d0ba0ad2afe93a27333d9c91deb347d6c99703eb8983d1ee5f480 mqtt-exec.aports-build.confd
ded99f4c9474e4dc91605de71919deebbeb8e2e3ebcc9d61890f327bb6220d891a9f2a6c615929cc53bd8007b1a1dbd827bc55cd5cbdd1a6661fcdafa4912950 report-build-errors.lua"
diff --git a/main/aports-build/aports-build b/main/aports-build/aports-build
index 7177ea2120..cecbad579d 100644
--- a/main/aports-build/aports-build
+++ b/main/aports-build/aports-build
@@ -43,12 +43,10 @@ repos=${REPOS:-"main community testing"}
upload_pkg="$upload_prefix/$rel/"
upload_iso="$upload_prefix/$rel/releases/$arch/"
-: ${ircchannel:="#alpine-devel"}
: ${hostname:=$(hostname)}
: ${mqtt_broker:="msg.alpinelinux.org"}
: ${status_msg:="mosquitto_pub -h $mqtt_broker -t build/$hostname -r -m"}
: ${upload_msg:="mosquitto_pub -h $mqtt_broker -t rsync/$upload_host/$rel/$arch -m"}
-: ${irc_msg:="mosquitto_pub -h $mqtt_broker -t irc/${ircchannel//#/%} -m"}
: ${logdir:="/var/cache/distfiles/buildlogs"}
: ${logurlprefix:="http://build.alpinelinux.org/buildlogs"}
@@ -57,15 +55,11 @@ log() {
$status_msg "$1"
}
-send_irc() {
- #echo "$1" | sircbot-send "$ircchannel"
- $irc_msg "$hostname: $1"
-}
-
# create new_release
create_release() {
local release="$1"
- local release_deps="abuild apk-tools alpine-conf busybox fakeroot xorriso rsync"
+ local release_deps="abuild apk-tools alpine-conf busybox fakeroot xorriso rsync
+ squashfs-tools acct mkinitfs mtools"
case "$arch" in
aarch64|arm*) release_deps="$release_deps mtools grub-efi";;
x86*) release_deps="$release_deps syslinux mtools grub-efi";;
@@ -110,7 +104,6 @@ while getopts "fFu:ns" opt; do
'n') use_network=false
status_msg="echo status_msg:"
upload_msg="echo upload_msg:"
- irc_msg="echo irc_msg:"
;;
's') skip_build=true;;
esac
@@ -162,6 +155,7 @@ while true; do
errlog=$hostname.$_current.log
cp "$logdir"/$hostname.log "$logdir"/$errlog
# todo: revert last commit?
+ log "failed"
exit 1
fi
@@ -183,8 +177,6 @@ while true; do
rc=1
elif [ -s /tmp/upload-$repo ]; then
$upload_msg "$rel/$repo/$arch"
- # report to irc that we are done with repo
- send_irc "files from $_current uploaded to $repo"
fi
done
done