aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-21 12:49:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-21 12:41:43 +0200
commite13872761f998baf7d00d9d5d69e1f05d3d68b83 (patch)
treeb82b934492478f36b8cae98442f6f76de98355ec /main
parent1f4e538f405c920db57eb7371adc9304c015dfb0 (diff)
downloadaports-e13872761f998baf7d00d9d5d69e1f05d3d68b83.tar.bz2
aports-e13872761f998baf7d00d9d5d69e1f05d3d68b83.tar.xz
main/pspg: upgrade to 1.2.1
Diffstat (limited to 'main')
-rw-r--r--main/pspg/APKBUILD15
-rw-r--r--main/pspg/fix-ax_with_curses_extra.patch30
2 files changed, 41 insertions, 4 deletions
diff --git a/main/pspg/APKBUILD b/main/pspg/APKBUILD
index 5ffbd749d7..5fbac8bb9e 100644
--- a/main/pspg/APKBUILD
+++ b/main/pspg/APKBUILD
@@ -1,16 +1,22 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pspg
-pkgver=1.1.1
+pkgver=1.2.1
pkgrel=0
pkgdesc="A unix pager optimized for psql"
url="https://github.com/okbob/pspg"
arch="all"
license="BSD-2-Clause"
-makedepends="ncurses-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz"
+makedepends="automake autoconf ncurses-dev readline-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz
+ fix-ax_with_curses_extra.patch"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
+
build() {
cd "$builddir"
./configure \
@@ -32,4 +38,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c8a0e9fe6033366ad00e56cc57d449068d932e484da9e3fef21b0c902857353f8df2685a3822e7ef333e3c3a41c296ab0ca527836575ccd88f04db2b1094db75 pspg-1.1.1.tar.gz"
+sha512sums="48de3416066c1098340057e2137c6ea05d9d3725550ef28bcadd9d74c323f5cc87e1bd39e84f3a66614d05f9656cb1206ca4b2146e506530906440d958788fc5 pspg-1.2.1.tar.gz
+81bd427880f57b92ff5ae9a781c9ccc3e30f1c6bb75f5367857706211f7619ed2a50c895908a4eb998b2c8fa62058079afc38d21a15e087093e8cccb21b347d8 fix-ax_with_curses_extra.patch"
diff --git a/main/pspg/fix-ax_with_curses_extra.patch b/main/pspg/fix-ax_with_curses_extra.patch
new file mode 100644
index 0000000000..d3110b3946
--- /dev/null
+++ b/main/pspg/fix-ax_with_curses_extra.patch
@@ -0,0 +1,30 @@
+From 2aedb98b7c0b60ebe2b347b5a511861146b2062d Mon Sep 17 00:00:00 2001
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sat, 21 Jul 2018 12:27:28 +0200
+Subject: [PATCH] fix ax_with_curses_extra to find <panel.h>
+
+These autohells macros do not find panel.h in the root of the library
+path when ncursesw variant is detected. This patch fixes the macros to
+search both ncursesw/ subdirectory and the root of the library path.
+
+Based on https://github.com/crosstool-ng/crosstool-ng/blob/master/m4/ax_with_curses_extra.m4
+
+Upstream-Issue: https://github.com/okbob/pspg/pull/72
+---
+ tools/m4_ax_with_curses_extra.m4 | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tools/m4_ax_with_curses_extra.m4 b/tools/m4_ax_with_curses_extra.m4
+index 7056d68..81f5b79 100644
+--- a/tools/m4_ax_with_curses_extra.m4
++++ b/tools/m4_ax_with_curses_extra.m4
+@@ -212,6 +212,9 @@ AC_DEFUN([_AX_WITH_CURSES_EXTRA], [
+ ], [
+ AS_IF([test "x$ax_cv_curses_which" = xncursesw], [
+ _AX_WITH_CURSES_CHECKEXTRA([$1], [$2], [$3], [ncursesw/$4], [$5])
++ AS_IF([test x$[]ax_cv_[]m4_tolower($1) != "xyes"], [
++ _AX_WITH_CURSES_CHECKEXTRA([$1], [$2], [$3], [$4], [$6])
++ ])
+ ], [test "x$ax_cv_curses_which" = xncurses], [
+ _AX_WITH_CURSES_CHECKEXTRA([$1], [$2], [$3], [$4], [$6])
+ AS_IF([test x$[]ax_cv_[]m4_tolower($1) != "xyes"], [