aboutsummaryrefslogtreecommitdiffstats
path: root/testing/2bwm
diff options
context:
space:
mode:
authordai9ah <dai9ah@protonmail.com>2018-02-08 20:37:34 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-05 11:44:30 +0000
commit99a2a25fa607e5410447cc11fcbf7cd584dd926e (patch)
treecf5d3e42b2eafa343616078eb8466451d2c2908e /testing/2bwm
parent71a193e96f8417873a63848ad474d6379617d9a0 (diff)
downloadaports-99a2a25fa607e5410447cc11fcbf7cd584dd926e.tar.bz2
aports-99a2a25fa607e5410447cc11fcbf7cd584dd926e.tar.xz
testing/2bwm: new aport
Diffstat (limited to 'testing/2bwm')
-rw-r--r--testing/2bwm/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/2bwm/APKBUILD b/testing/2bwm/APKBUILD
new file mode 100644
index 0000000000..e72e83879f
--- /dev/null
+++ b/testing/2bwm/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: dai9ah <dai9ah@protonmail.com>
+# Maintainer: dai9ah <dai9ah@protonmail.com>
+pkgname=2bwm
+pkgver=0.2
+pkgrel=0
+pkgdesc="Fast floating window manager"
+url="https://github.com/venam/2bwm"
+arch="all"
+license="ISC"
+makedepends="libxcb-dev xcb-util-keysyms-dev xcb-util-wm-dev xcb-util-xrm-dev"
+options="!check" # no test suite or working check function
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/venam/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ sed -i "$builddir"/Makefile \
+ -e '/CFLAGS/{s/+=-Os/ +=/}'
+}
+
+build() {
+ make -C "$builddir"
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" -C "$builddir" install
+}
+
+sha512sums="e2a9c6bd41818b79bcf5b1e9fa789d829921c1cee9351783f8b3a20a7efc4641fb8a6bd04485c97895a8161737d02efe55014781d29e89b9e84fcf1e0aef2c2e 2bwm-0.2.tar.gz"