aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bgs
diff options
context:
space:
mode:
authordai9ah <dai9ah@protonmail.com>2018-02-06 20:03:45 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-05 11:41:55 +0000
commitabd16aa54c70c8300e412bed88c34b7d8a8023db (patch)
tree827fc20b88fee70d1d9b5eade57d8da364db4e6d /testing/bgs
parent8c1214b0060ac8c930673eec1aaeefbd42f54556 (diff)
downloadaports-abd16aa54c70c8300e412bed88c34b7d8a8023db.tar.bz2
aports-abd16aa54c70c8300e412bed88c34b7d8a8023db.tar.xz
testing/bgs: new package
Diffstat (limited to 'testing/bgs')
-rw-r--r--testing/bgs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/bgs/APKBUILD b/testing/bgs/APKBUILD
new file mode 100644
index 0000000000..b886bd9c9b
--- /dev/null
+++ b/testing/bgs/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: dai9ah <dai9ah@protonmail.com>
+# Maintainer: dai9ah <dai9ah@protonmail.com>
+pkgname=bgs
+pkgver=0.8
+pkgrel=0
+pkgdesc="Extremely fast and small background setter for X"
+url="https://github.com/Gottox/bgs"
+arch="all"
+license="MIT"
+makedepends="imlib2-dev libxinerama-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Gottox/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ sed -i "$builddir/config.mk" \
+ -e "/CFLAGS/s|\${CPPFLAGS}|& $CFLAGS|g" \
+ -e "/LDFLAGS/s|\-s|$LDFLAGS|g"
+}
+
+build() {
+ make -C "$builddir"
+}
+
+check() {
+ cd "$builddir"
+ ./bgs -v > /dev/null
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" -C "$builddir" install
+}
+
+sha512sums="4f7aa32d9cf60252abfc87cf72c7bc20ac691af3684a0923d3e2a3506407bddee9d2e5f49da97a154ed2acf1a876b2952ab61dd412f2de39c1303e7551acaec8 bgs-0.8.tar.gz"