aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bird
diff options
context:
space:
mode:
authorFusl <root@hallowe.lt>2018-02-16 06:48:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-27 17:46:03 +0000
commit61818fd63b50c0c30c320b6e7624184120b42b7e (patch)
tree5001c1197ea901aecc262d0ff3fea5a96375a202 /testing/bird
parent0211a7b11bf19bdb0d5a4b5f9d5cd785c290ea6f (diff)
downloadaports-61818fd63b50c0c30c320b6e7624184120b42b7e.tar.bz2
aports-61818fd63b50c0c30c320b6e7624184120b42b7e.tar.xz
testing/bird: upgrade to 2.0.1
Diffstat (limited to 'testing/bird')
-rw-r--r--testing/bird/APKBUILD11
-rw-r--r--testing/bird/bird-make-test-bsprintf.patch20
2 files changed, 29 insertions, 2 deletions
diff --git a/testing/bird/APKBUILD b/testing/bird/APKBUILD
index ab0c3fc1ec..30dcad5806 100644
--- a/testing/bird/APKBUILD
+++ b/testing/bird/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Katie Holly <holly@fuslvz.ws>
# Maintainer: Francesco Zanini <francesco@zanini.me>
pkgname=bird
-pkgver=2.0.0
+pkgver=2.0.1
pkgrel=0
pkgdesc="BIRD Internet Routing Daemon"
url="http://bird.network.cz/"
@@ -13,6 +13,7 @@ makedepends="bison flex ncurses-dev readline-dev linux-headers"
install=""
source="
ftp://bird.network.cz/pub/bird/bird-$pkgver.tar.gz
+ bird-make-test-bsprintf.patch
bird.initd
"
builddir="$srcdir"/bird-$pkgver
@@ -32,11 +33,17 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/bird.initd "$pkgdir"/etc/init.d/bird
}
-sha512sums="62d39c35a25b621bbab7e4760e295c6a11b7b4ed048f5c897715401c33c5d49b804584cdd13ee337ca834f20eca4a3646919ce9035ae982fae8f2f682aa8ad06 bird-2.0.0.tar.gz
+sha512sums="4ca4d5aa57d1262b69511446cd1d70bd5f48d69a42b12aa617afdbf7ed69f73ace67b9606126c0799e1151ca5539ae891f58423568ec2dfb341d06311bee624c bird-2.0.1.tar.gz
+e0a9bab1bb84ab4efbf51c4c015bf35196d146560f737979d3a17c44dc2397d9578e61a3bba0c58f3cdbb108074f17288bf536db5d8d4dce87c91f1be3dc6282 bird-make-test-bsprintf.patch
59245af3fd514421d0babcefed556597022a36d14615d596bb5c08c7dd0a6ed4519928e35a0b7ff14fe27ecfa50fa8011283c92bfc9b8355b15b3263df189d5d bird.initd"
diff --git a/testing/bird/bird-make-test-bsprintf.patch b/testing/bird/bird-make-test-bsprintf.patch
new file mode 100644
index 0000000000..d42027c374
--- /dev/null
+++ b/testing/bird/bird-make-test-bsprintf.patch
@@ -0,0 +1,20 @@
+diff -urp a/lib/printf_test.c b/lib/printf_test.c
+--- a/lib/printf_test.c 1970-01-01 00:00:00.000000000 +0000
++++ b/lib/printf_test.c 1970-01-01 00:00:00.000000000 +0000
+@@ -33,10 +33,14 @@ t_simple(void)
+ BSPRINTF(1, "\xff", buf, "%c", 0xff);
+
+ errno = 5;
+- BSPRINTF(18, "Input/output error", buf, "%m");
++ // glibc returns "Input/output error" while musl-libc returns "I/O error"
++ //BSPRINTF(18, "Input/output error", buf, "%m");
++ BSPRINTF(9, "I/O error", buf, "%m");
+ errno = 0;
+
+- BSPRINTF(18, "Input/output error", buf, "%M", 5);
++ // glibc returns "Input/output error" while musl-libc returns "I/O error"
++ //BSPRINTF(18, "Input/output error", buf, "%M", 5);
++ BSPRINTF(9, "I/O error", buf, "%M", 5);
+
+ BSPRINTF(11, "TeSt%StRiNg", buf, "%s", "TeSt%StRiNg");
+