aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cloudfoundry-cli
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-05-12 12:21:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-04 18:03:55 +0200
commit83872d38a695f70427c1e81c16b19c977d0b0210 (patch)
tree9360d0a2b7d7a4243db0e3aa8851596a932094df /testing/cloudfoundry-cli
parent4722b9d6b13e102be8dc4d856e04f0026d57c4d8 (diff)
downloadaports-83872d38a695f70427c1e81c16b19c977d0b0210.tar.bz2
aports-83872d38a695f70427c1e81c16b19c977d0b0210.tar.xz
testing/cloudfoundry-cli: new aport
https://github.com/cloudfoundry/cli A CLI for Cloud Foundry written in Go
Diffstat (limited to 'testing/cloudfoundry-cli')
-rw-r--r--testing/cloudfoundry-cli/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/cloudfoundry-cli/APKBUILD b/testing/cloudfoundry-cli/APKBUILD
new file mode 100644
index 0000000000..b8733042bf
--- /dev/null
+++ b/testing/cloudfoundry-cli/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=cloudfoundry-cli
+pkgver=6.18.0
+pkgrel=0
+pkgdesc="A CLI for Cloud Foundry written in Go"
+url="https://github.com/cloudfoundry/cli"
+arch="all"
+license="Apache 2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev go bash"
+install=""
+subpackages=""
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/cloudfoundry/cli/archive/v$pkgver.tar.gz"
+
+_builddir="${srcdir}/cli-${pkgver}"
+_godir="${srcdir}/go"
+_gourl="github.com/cloudfoundry/cli"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ mkdir -p ${_godir}/bin ${_godir}/src/github.com/cloudfoundry
+ ln -sf ${_builddir} ${_godir}/src/github.com/cloudfoundry/cli
+
+ export GOPATH="${_godir}"
+ go install ${_gourl}/main
+}
+
+package() {
+ cd "$_godir"/bin
+
+ install -Dm755 main \
+ "${pkgdir}/usr/bin/cf" || return 1
+}
+
+md5sums="78a6e60400c5478cce02f18e8933faa4 cloudfoundry-cli-6.18.0.tar.gz"
+sha256sums="499fdd87c595d5da4f8f9d1208633247fcc75040d37fbd9a75457e3d309722f8 cloudfoundry-cli-6.18.0.tar.gz"
+sha512sums="d514fc7a76602744282ddeb39e46b7fce3817526046774a42e0aaee28d21bf689fc17a53515044cc10e1a7a2a286ab1cf22072d1d251080926683f2d5a350b56 cloudfoundry-cli-6.18.0.tar.gz"